aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-panel-2
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-10 19:30:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:12 +0100
commitfa1d9b518708103b0b2e259aa78f8dd694cfc0d6 (patch)
treea0929bb5131b622f3a3271f0c16341fad9b4477d /meta/recipes-sato/matchbox-panel-2
parent6a71e9063b2f509bb35e63c3b9951df16f555c88 (diff)
downloadopenembedded-core-fa1d9b518708103b0b2e259aa78f8dd694cfc0d6.tar.gz
recipes-sato: add x11 to REQUIRED_DISTRO_FEATURES
They can't be built withou x11 in DISTRO_FEATURES. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-panel-2')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
index 490e2bc86b..4ed7368fd0 100644
--- a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
@@ -11,6 +11,9 @@ DEPENDS = "gnome-common gtk+ startup-notification dbus dbus-glib"
DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
+# The startup-notification requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
SRCREV = "26a3a67b41c50e0ae163d8fe86ccf7a0f0a671ae"
PV = "2.0+git${SRCPV}"
@@ -33,4 +36,4 @@ FILES_${PN} += "${libdir}/matchbox-panel/*.so \
FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
FILES_${PN}-dev += "${libdir}/matchbox-panel/*.la"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check