summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-panel-2
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2011-04-28 11:05:26 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-04 00:49:02 +0100
commitace616b362bbcba9d9c78a2814a9cb943ac3f4a2 (patch)
tree4b7340529457607354e564ca780a1a9e2659a88e /meta/recipes-sato/matchbox-panel-2
parent74040af7c44718e05b1f0eeccb267afa1aa6d3f6 (diff)
downloadopenembedded-core-ace616b362bbcba9d9c78a2814a9cb943ac3f4a2.tar.gz
Fix matchbox-panel-2 compile error
This patch is needed when building with GCC-4.6.0 -- ------------------------------------------------------------ Gary Thomas | Consulting for the MLB Associates | Embedded world ------------------------------------------------------------ >From 7337ecd4970f7d94080ad70b912bdb2742d2d7aa Mon Sep 17 00:00:00 2001 From: Gary Thomas <gary@mlbassoc.com> Date: Thu, 28 Apr 2011 11:03:44 -0600 Subject: [PATCH] matchbox-panel: fix compile error with GCC-4.6.0 Upstream-Status: Pending [sgw: added Upstream-Status] Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-panel-2')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/gcc-4.6.0-compile.patch51
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb5
2 files changed, 54 insertions, 2 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/gcc-4.6.0-compile.patch b/meta/recipes-sato/matchbox-panel-2/gcc-4.6.0-compile.patch
new file mode 100644
index 0000000000..54ca74d8ce
--- /dev/null
+++ b/meta/recipes-sato/matchbox-panel-2/gcc-4.6.0-compile.patch
@@ -0,0 +1,51 @@
+diff -ur git.ORIG/applets/startup/startup.c git/applets/startup/startup.c
+--- git.ORIG/applets/startup/startup.c 2011-04-28 08:13:25.000000000 -0600
++++ git/applets/startup/startup.c 2011-04-28 09:36:48.521990746 -0600
+@@ -210,9 +210,8 @@
+ {
+ XEvent *xevent;
+ xevent = (XEvent *) gdk_xevent;
+- gboolean ret;
+
+- ret = sn_display_process_event (applet->sn_display, xevent);
++ sn_display_process_event (applet->sn_display, xevent);
+
+ return GDK_FILTER_CONTINUE;
+ }
+@@ -223,7 +222,6 @@
+ {
+ StartupApplet *applet;
+ Display *xdisplay;
+- SnMonitorContext *context;
+
+ /* Create applet data structure */
+ applet = g_slice_new0 (StartupApplet);
+@@ -248,7 +246,7 @@
+
+ applet->sn_display = sn_display_new (xdisplay, NULL, NULL);
+
+- context = sn_monitor_context_new (applet->sn_display,
++ sn_monitor_context_new (applet->sn_display,
+ DefaultScreen(xdisplay),
+ monitor_event_func,
+ (void *) applet,
+diff -ur git.ORIG/applets/startup-notify/startup.c git/applets/startup-notify/startup.c
+--- git.ORIG/applets/startup-notify/startup.c 2011-04-28 08:05:46.000000000 -0600
++++ git/applets/startup-notify/startup.c 2011-04-28 09:42:17.793864786 -0600
+@@ -305,7 +305,6 @@
+ StartupApplet *applet;
+ GtkWidget *widget;
+ Display *xdisplay;
+- SnMonitorContext *context;
+
+ applet = g_slice_new0 (StartupApplet);
+
+@@ -317,7 +316,7 @@
+
+ applet->sn_display = sn_display_new (xdisplay, NULL, NULL);
+
+- context = sn_monitor_context_new (applet->sn_display,
++ sn_monitor_context_new (applet->sn_display,
+ DefaultScreen (xdisplay),
+ monitor_event_func,
+ applet, NULL);
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
index 9e1a29700b..9c1aa010c3 100644
--- a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
@@ -13,13 +13,14 @@ DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
PV = "0.0+git${SRCPV}"
-PR = "r0"
+PR = "r1"
RPROVIDES_${PN} = "matchbox-panel"
RREPLACES_${PN} = "matchbox-panel"
RCONFLICTS_${PN} = "matchbox-panel"
-SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
+SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
+ file://gcc-4.6.0-compile.patch \
file://startup_fix.diff;patch=1"
EXTRA_OECONF = "--enable-startup-notification --enable-dbus"