summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-sato/pcmanfm
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/pcmanfm')
-rw-r--r--meta/recipes-sato/pcmanfm/files/cross-compile-fix.patch16
-rw-r--r--meta/recipes-sato/pcmanfm/files/emblem-symbolic-link.pngbin0 -> 999 bytes
-rw-r--r--meta/recipes-sato/pcmanfm/files/gnome-fs-directory.pngbin0 -> 2044 bytes
-rw-r--r--meta/recipes-sato/pcmanfm/files/gnome-fs-regular.pngbin0 -> 3220 bytes
-rw-r--r--meta/recipes-sato/pcmanfm/files/gnome-mime-text-plain.pngbin0 -> 2855 bytes
-rw-r--r--meta/recipes-sato/pcmanfm/files/owl-window-menu.patch80
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_0.9.7.bb35
7 files changed, 131 insertions, 0 deletions
diff --git a/meta/recipes-sato/pcmanfm/files/cross-compile-fix.patch b/meta/recipes-sato/pcmanfm/files/cross-compile-fix.patch
new file mode 100644
index 0000000000..2f654a5fb6
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/files/cross-compile-fix.patch
@@ -0,0 +1,16 @@
+pcmanfm need a binary xml-purge(from its own source code) to optimize size of
+data file, which cause build error on cross-compile environment. Simplely
+remove it to work aound this issue.
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: pcmanfm-0.9.7/data/ui/Makefile.am
+===================================================================
+--- pcmanfm-0.9.7.orig/data/ui/Makefile.am 2010-07-29 15:10:18.000000000 +0800
++++ pcmanfm-0.9.7/data/ui/Makefile.am 2010-07-29 15:11:24.000000000 +0800
+@@ -21,4 +21,4 @@
+ # Purge GtkBuilder UI files
+ %.ui: %.glade
+ cp $< $@
+- $(top_builddir)/src/xml-purge $@
++# $(top_builddir)/src/xml-purge $@
diff --git a/meta/recipes-sato/pcmanfm/files/emblem-symbolic-link.png b/meta/recipes-sato/pcmanfm/files/emblem-symbolic-link.png
new file mode 100644
index 0000000000..b8e559456e
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/files/emblem-symbolic-link.png
Binary files differ
diff --git a/meta/recipes-sato/pcmanfm/files/gnome-fs-directory.png b/meta/recipes-sato/pcmanfm/files/gnome-fs-directory.png
new file mode 100644
index 0000000000..05921a6689
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/files/gnome-fs-directory.png
Binary files differ
diff --git a/meta/recipes-sato/pcmanfm/files/gnome-fs-regular.png b/meta/recipes-sato/pcmanfm/files/gnome-fs-regular.png
new file mode 100644
index 0000000000..ce77a8e62d
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/files/gnome-fs-regular.png
Binary files differ
diff --git a/meta/recipes-sato/pcmanfm/files/gnome-mime-text-plain.png b/meta/recipes-sato/pcmanfm/files/gnome-mime-text-plain.png
new file mode 100644
index 0000000000..bfe4bad56c
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/files/gnome-mime-text-plain.png
Binary files differ
diff --git a/meta/recipes-sato/pcmanfm/files/owl-window-menu.patch b/meta/recipes-sato/pcmanfm/files/owl-window-menu.patch
new file mode 100644
index 0000000000..f3d4e61a22
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/files/owl-window-menu.patch
@@ -0,0 +1,80 @@
+0.9.7 use a new menu bar from gtk_ui_manager, so need a translation here to
+enable owl menu
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: pcmanfm-0.9.7/configure.ac
+===================================================================
+--- pcmanfm-0.9.7.orig/configure.ac 2010-07-27 10:28:12.000000000 +0800
++++ pcmanfm-0.9.7/configure.ac 2010-07-27 18:03:42.000000000 +0800
+@@ -70,6 +70,8 @@
+
+ gtk_modules="gtk+-2.0 >= 2.16.0"
+ PKG_CHECK_MODULES(GTK, [$gtk_modules])
++OWL_LIBS="-lowl"
++GTK_LIBS="$GTK_LIBS $OWL_LIBS"
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
+Index: pcmanfm-0.9.7/src/main-win.c
+===================================================================
+--- pcmanfm-0.9.7.orig/src/main-win.c 2010-07-27 10:56:08.000000000 +0800
++++ pcmanfm-0.9.7/src/main-win.c 2010-07-27 17:28:59.000000000 +0800
+@@ -36,6 +36,8 @@
+ #include "main-win.h"
+ #include "pref.h"
+
++#include "libowl/owlwindowmenu.h"
++
+ static void fm_main_win_finalize (GObject *object);
+ G_DEFINE_TYPE(FmMainWin, fm_main_win, GTK_TYPE_WINDOW);
+
+@@ -466,9 +468,27 @@
+ fm_main_win_chdir(win, path);
+ }
+
++/* Transfer gtk_ui_manager menubar to gtk menubar */
++static GtkWidget * ui_menubar_to_menu(GtkWidget *menubar)
++{
++ GtkWidget *main_menu;
++ GList *iter;
++
++ main_menu = gtk_menu_new();
++
++ for ( iter = gtk_container_get_children(GTK_CONTAINER(menubar));
++ iter;
++ iter = g_list_next(iter) )
++ {
++ GtkWidget *menu = GTK_WIDGET(iter->data);
++ gtk_widget_reparent(menu, main_menu);
++ }
++ return main_menu;
++}
++
+ static void fm_main_win_init(FmMainWin *self)
+ {
+- GtkWidget *vbox, *menubar, *toolitem, *scroll;
++ GtkWidget *vbox, *menubar, *owl_menubar, *toolitem, *scroll;
+ GtkUIManager* ui;
+ GtkActionGroup* act_grp;
+ GtkAction* act;
+@@ -537,7 +557,6 @@
+
+ self->popup = gtk_ui_manager_get_widget(ui, "/popup");
+
+- gtk_box_pack_start( (GtkBox*)vbox, menubar, FALSE, TRUE, 0 );
+ gtk_box_pack_start( (GtkBox*)vbox, self->toolbar, FALSE, TRUE, 0 );
+
+ /* load bookmarks menu */
+@@ -586,6 +605,11 @@
+ gtk_container_add( (GtkContainer*)self, vbox );
+ gtk_widget_show_all(vbox);
+
++ owl_menubar = ui_menubar_to_menu(menubar);
++ gtk_widget_show_all (owl_menubar);
++ owl_set_window_menu (GTK_WINDOW(self),
++ GTK_MENU(owl_menubar));
++
+ /* create new tab */
+ fm_main_win_add_tab(self, fm_path_get_home());
+ gtk_widget_grab_focus(self->folder_view);
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_0.9.7.bb b/meta/recipes-sato/pcmanfm/pcmanfm_0.9.7.bb
new file mode 100644
index 0000000000..46e46da685
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_0.9.7.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Fast lightweight tabbed filemanager"
+HOMEPAGE = "http://pcmanfm.sourceforge.net/"
+BUGTRACKER = ""
+
+LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://src/pcmanfm.h;endline=22;md5=417b3855771a3a87f8ad753d994491f0 \
+ file://src/gseal-gtk-compat.h;endline=21;md5=46922c8691f58d124f9420fe16149ce2"
+
+SECTION = "x11"
+PRIORITY = "optional"
+DEPENDS = "gtk+ startup-notification libfm"
+DEPENDS_append_poky = " libowl"
+
+PR = "r0"
+
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|mips.*|powerpc.*)-(linux|freebsd.*)'
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
+ file://gnome-fs-directory.png \
+ file://gnome-fs-regular.png \
+ file://gnome-mime-text-plain.png \
+ file://emblem-symbolic-link.png \
+ file://cross-compile-fix.patch"
+
+SRC_URI_append_poky = " file://owl-window-menu.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}/${datadir}
+ install -d ${D}/${datadir}/pixmaps/
+
+ install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
+}