aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/sato-screenshot
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2011-11-15 12:58:46 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-16 17:29:18 +0000
commit5423d2fabade45974f20948a6d90a663eead209a (patch)
tree4b8a597d40d37f7ebdf75c086e4f3a3a75b09060 /meta/recipes-sato/sato-screenshot
parentda7bf75bcdd5759a0f551dcb7a0326aa2f40921c (diff)
downloadopenembedded-core-5423d2fabade45974f20948a6d90a663eead209a.tar.gz
screenshot: rename to sato-screenshot
To remove a name conflict with e17's screenshot tool (and possibly other screenshot tools, as screenshot is a generic term), rename screenshot to sato-screenshot. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/sato-screenshot')
-rw-r--r--meta/recipes-sato/sato-screenshot/files/fix_ldadd_order.patch15
-rw-r--r--meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb23
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-sato/sato-screenshot/files/fix_ldadd_order.patch b/meta/recipes-sato/sato-screenshot/files/fix_ldadd_order.patch
new file mode 100644
index 0000000000..7d9689e893
--- /dev/null
+++ b/meta/recipes-sato/sato-screenshot/files/fix_ldadd_order.patch
@@ -0,0 +1,15 @@
+Fix the ordering of LDADD options to fix a compilation failure.
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+Upstream-Status: Inappropriate [configuration]
+
+diff -urN screenshot.orig//Makefile.am screenshot/Makefile.am
+--- screenshot.orig//Makefile.am 2010-06-29 11:55:00.000000000 -0700
++++ screenshot/Makefile.am 2011-03-01 11:09:01.215813968 -0800
+@@ -23,4 +23,4 @@
+ # A standalone tool for running from a terminal and scripts
+ bin_PROGRAMS = screenshot
+ screenshot_SOURCES = main.c
+-screenshot_LDADD = $(GTK_LIBS) libshot.la
++screenshot_LDADD = libshot.la $(GTK_LIBS)
diff --git a/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb b/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb
new file mode 100644
index 0000000000..5e51d3dfd9
--- /dev/null
+++ b/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "An ultra-simple screen capture utility, aimed at handheld devices"
+HOMEPAGE = "http://www.o-hand.com"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
+
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://main.c;endline=9;md5=023e14d6404d0a961eb97cbd011fc141 \
+ file://screenshot-ui.h;endline=9;md5=638d9ffa83e9325a36df224166ed6ad0"
+
+DEPENDS = "matchbox-panel-2"
+SRCREV = "c792e4edc758bab21e0b01814979eacf0b1af945"
+PV = "0.1+git${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.yoctoproject.org/screenshot;protocol=git \
+ file://fix_ldadd_order.patch"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/matchbox-panel/*.so"
+FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"