aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/sato-screenshot
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-10 19:30:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:12 +0100
commitfa1d9b518708103b0b2e259aa78f8dd694cfc0d6 (patch)
treea0929bb5131b622f3a3271f0c16341fad9b4477d /meta/recipes-sato/sato-screenshot
parent6a71e9063b2f509bb35e63c3b9951df16f555c88 (diff)
downloadopenembedded-core-fa1d9b518708103b0b2e259aa78f8dd694cfc0d6.tar.gz
recipes-sato: add x11 to REQUIRED_DISTRO_FEATURES
They can't be built withou x11 in DISTRO_FEATURES. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-sato/sato-screenshot')
-rw-r--r--meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb b/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb
index a079e03d97..8794032d25 100644
--- a/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb
+++ b/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb
@@ -16,7 +16,7 @@ SRC_URI = "git://git.yoctoproject.org/screenshot"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
FILES_${PN} += "${libdir}/matchbox-panel/*.so"
FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
@@ -24,3 +24,6 @@ FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
do_install_append () {
rm ${D}${libdir}/matchbox-panel/*.la
}
+
+# The matchbox-panel-2 requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"