aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/shutdown-desktop
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:40 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commit738005f4713c0da7bc04582a41efa956efdb9cc0 (patch)
tree6fa45eff2351a79ae9fbc16acb2a5ff3a118a4c5 /meta/recipes-sato/shutdown-desktop
parent3063126e2c8ec72e900a48f7048aaf9662606792 (diff)
downloadopenembedded-core-738005f4713c0da7bc04582a41efa956efdb9cc0.tar.gz
qemu-config: split out shutdown icon to its own recipe
Cleanly shutting down the machine from Sato is useful on other machines, not all of which have a power button that otherwise enables this, so make it not specific to qemu* and add it to task-core-x11-sato. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/shutdown-desktop')
-rw-r--r--meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb20
-rw-r--r--meta/recipes-sato/shutdown-desktop/shutdown-desktop/shutdown.desktop10
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
new file mode 100644
index 0000000000..d0f507e673
--- /dev/null
+++ b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Provides an icon to shut down the system cleanly"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://shutdown.desktop"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 shutdown.desktop ${D}${datadir}/applications/
+}
+
+pkg_postinst_${PN} () {
+ grep -q qemuarm $D${sysconfdir}/hostname && \
+ sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
+}
+
+inherit allarch
diff --git a/meta/recipes-sato/shutdown-desktop/shutdown-desktop/shutdown.desktop b/meta/recipes-sato/shutdown-desktop/shutdown-desktop/shutdown.desktop
new file mode 100644
index 0000000000..272688922c
--- /dev/null
+++ b/meta/recipes-sato/shutdown-desktop/shutdown-desktop/shutdown.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Shutdown
+Comment=Close down the machine safely
+Exec=halt
+Icon=system-shutdown
+Terminal=false
+Categories=Utility;
+StartupNotify=true \ No newline at end of file