aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/web
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-sato/web
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/web')
-rw-r--r--meta/recipes-sato/web/web-webkit/link-with-g++.patch32
-rw-r--r--meta/recipes-sato/web/web-webkit_svn.bb26
-rw-r--r--meta/recipes-sato/web/web/owl-window-menu.patch100
-rw-r--r--meta/recipes-sato/web/web_svn.bb16
4 files changed, 174 insertions, 0 deletions
diff --git a/meta/recipes-sato/web/web-webkit/link-with-g++.patch b/meta/recipes-sato/web/web-webkit/link-with-g++.patch
new file mode 100644
index 0000000000..50d6e93792
--- /dev/null
+++ b/meta/recipes-sato/web/web-webkit/link-with-g++.patch
@@ -0,0 +1,32 @@
+The main webkit library links against stdc++ so we need to use g++ for
+linking. The easiest way to achieve this is to add a dummy cpp file.
+This also means we have to add AC_PROG_CXX else libtool 2.2.2 gets upset.
+
+RP - 14/4/08
+--- webkit.orig/src/Makefile.am
++++ webkit/src/Makefile.am
+@@ -1,11 +1,11 @@
+ AM_CPPFLAGS=-DPKGDATADIR=\"$(pkgdatadir)\"
+ AM_CFLAGS = -Wall -export-dynamic $(WEB_CFLAGS)
+
+ bin_PROGRAMS = web2
+
+-web2_SOURCES = web2.h web2-main.c web2-utils.c web2-utils.h
++web2_SOURCES = web2.h web2-main.c web2-utils.c web2-utils.h dummy.cpp
+ web2_LDADD = $(WEB_LIBS)
+
+ MAINTAINERCLEANFILES = config.h.in Makefile.in
+
+ uidir = $(pkgdatadir)
+Index: webkit/configure.ac
+===================================================================
+--- webkit.orig/configure.ac 2008-04-14 22:15:25.000000000 +0100
++++ webkit/configure.ac 2008-04-14 22:16:31.000000000 +0100
+@@ -7,6 +7,7 @@
+
+ AC_ISC_POSIX
+ AC_PROG_CC
++AC_PROG_CXX
+ AC_STDC_HEADERS
+ AC_PROG_LIBTOOL
+
diff --git a/meta/recipes-sato/web/web-webkit_svn.bb b/meta/recipes-sato/web/web-webkit_svn.bb
new file mode 100644
index 0000000000..9cdf1f9da3
--- /dev/null
+++ b/meta/recipes-sato/web/web-webkit_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Multi-platform web browsing application."
+HOMEPAGE = "http://o-hand.com/"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
+
+LICENSE = "GPLv2"
+
+SECTION = "x11"
+DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "svn://svn.o-hand.com/repos/web/branches;module=webkit;proto=http \
+ file://link-with-g++.patch;patch=1"
+
+S = "${WORKDIR}/webkit"
+
+EXTRA_OECONF = "--enable-libowl"
+
+inherit autotools pkgconfig gconf
+
+do_configure_prepend() {
+ touch ${S}/src/dummy.cpp
+}
+
+FILES_${PN} += "${datadir}/web2"
diff --git a/meta/recipes-sato/web/web/owl-window-menu.patch b/meta/recipes-sato/web/web/owl-window-menu.patch
new file mode 100644
index 0000000000..6e60dd0893
--- /dev/null
+++ b/meta/recipes-sato/web/web/owl-window-menu.patch
@@ -0,0 +1,100 @@
+Index: trunk/src/web_main.c
+===================================================================
+--- trunk.orig/src/web_main.c 2007-04-19 15:41:44.000000000 +0100
++++ trunk/src/web_main.c 2007-04-26 07:43:23.000000000 +0100
+@@ -20,6 +20,8 @@
+ #include "web_bookmarks.h"
+ #include "web_request.h"
+
++#include <libowl/owlwindowmenu.h>
++
+ static void
+ copy_cb (GtkWindow *main_window)
+ {
+@@ -833,10 +835,8 @@
+ main (int argc, char **argv)
+ {
+ GtkWidget *widget;
+-#ifdef WITH_HILDON
+ GList *children, *c;
+ GtkMenu *menu;
+-#endif
+ WebPages pages;
+ GConfClient *client;
+ GModule *module;
+@@ -889,33 +889,12 @@
+ WEB_API_VERSION, pages.backend->api_version);
+ pages.backend->init (&(pages.backend_data), &pages);
+
+-#ifdef WITH_HILDON
+- osso_initialize ("web", "0.0", FALSE, NULL);
+- pages.appview = hildon_appview_new ("");
+- pages.window = hildon_app_new_with_appview (pages.appview);
+- hildon_app_set_title (pages.window, "Web");
+- gtk_widget_show (pages.appview);
+-
+- /* Reparent widgets to hildon appview */
+- widget = glade_xml_get_widget (pages.xml, "main_vbox");
+- gtk_container_remove (
+- GTK_CONTAINER (gtk_widget_get_parent (widget)),
+- g_object_ref (widget));
+- gtk_container_add (GTK_CONTAINER (pages.appview), widget);
+-
+- widget = glade_xml_get_widget (pages.xml, "main_toolbar");
+- gtk_container_remove (
+- GTK_CONTAINER (gtk_widget_get_parent (widget)),
+- g_object_ref (widget));
+- gtk_box_pack_end (GTK_BOX (pages.appview->vbox),
+- widget, TRUE, TRUE, 0);
+- gtk_widget_show_all (GTK_WIDGET (pages.appview->vbox));
+-
+- gtk_widget_destroy (glade_xml_get_widget (pages.xml, "main_window"));
++ pages.window = glade_xml_get_widget (pages.xml, "main_window");
+
+ /* Reparent menu items */
+ widget = glade_xml_get_widget (pages.xml, "main_menubar");
+- menu = hildon_appview_get_menu (pages.appview);
++ menu = gtk_menu_new ();
++
+ children = gtk_container_get_children (GTK_CONTAINER (widget));
+ for (c = children; c; c = c->next) {
+ GtkWidget *menuitem = GTK_WIDGET (c->data);
+@@ -926,12 +905,6 @@
+ gtk_widget_destroy (widget);
+ g_list_free (children);
+
+- g_signal_connect (G_OBJECT (pages.window),
+- "key_press_event", G_CALLBACK (web_key_press_cb), &pages);
+-#else
+- pages.window = glade_xml_get_widget (pages.xml, "main_window");
+-#endif
+-
+ web_bookmarks_init (&pages);
+
+ /* Set history menus */
+@@ -1064,6 +1037,8 @@
+
+ gtk_widget_show (pages.window);
+
++ owl_set_window_menu (GTK_WINDOW(pages.window), GTK_MENU(menu));
++
+ gtk_main ();
+
+ g_module_close (module);
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac 2007-04-19 15:41:44.000000000 +0100
++++ trunk/configure.ac 2007-04-25 20:36:34.000000000 +0100
+@@ -14,6 +14,12 @@
+
+ PKG_CHECK_MODULES(WEB, libxml-2.0 glib-2.0 gthread-2.0 gtk+-2.0 libglade-2.0 gconf-2.0 gobject-2.0)
+
++OWL_CFLAGS=""
++OWL_LIBS="-lowl"
++
++WEB_CFLAGS="$WEB_CFLAGS $OWL_CFLAGS"
++WEB_LIBS="$WEB_LIBS $OWL_LIBS"
++
+ # -- Hildon stuff for Maemo
+ hildon=false
+ AC_ARG_ENABLE(hildon,AS_HELP_STRING([--enable-hildon],[Turn on hildon support]),[
diff --git a/meta/recipes-sato/web/web_svn.bb b/meta/recipes-sato/web/web_svn.bb
new file mode 100644
index 0000000000..583be4aa24
--- /dev/null
+++ b/meta/recipes-sato/web/web_svn.bb
@@ -0,0 +1,16 @@
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "libxml2 glib-2.0 gtk+ libglade gtkhtml2 curl gconf js libowl"
+DESCRIPTION = "Web is a multi-platform web browsing application."
+PR = "r2"
+
+PV = "0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
+ file://owl-window-menu.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig gconf
+