summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2017-12-29 10:00:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-04 12:54:43 +0000
commitdbd604ccf34e304769937b15051c047561de47f7 (patch)
treebed98e4e11080d9f352754b70d9c4f3f154e5df0 /meta/recipes-sato/webkit
parentfeed576321dcba2d75c067d6ee8b8dad817e9bba (diff)
downloadopenembedded-core-dbd604ccf34e304769937b15051c047561de47f7.tar.gz
webkitgtk: fix build with musl and x32
Make the x32 check generic to make it work with musl as well. Fixes [YOCTO #12118] Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.18.3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.18.3.bb b/meta/recipes-sato/webkit/webkitgtk_2.18.3.bb
index 00b5a15e08..4938f69b7b 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.18.3.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.18.3.bb
@@ -66,6 +66,7 @@ EXTRA_OECMAKE = " \
# GL/GLES header clash: both define the same thing, differently, on 32 bit x86
EXTRA_OECMAKE_append_x86 = " -DUSE_GSTREAMER_GL=OFF "
+EXTRA_OECMAKE_append_x86-x32 = " -DUSE_GSTREAMER_GL=OFF "
# Javascript JIT is not supported on powerpc
EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
@@ -92,7 +93,7 @@ EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF "
# An attempt was made to upstream JIT support for x32 in
# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
# unresolved due to limited X32 adoption.
-EXTRA_OECMAKE_append_linux-gnux32 = " -DENABLE_JIT=OFF"
+EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
SECURITY_CFLAGS_remove_aarch64 = "-fpie"
SECURITY_CFLAGS_append_aarch64 = " -fPIE"