aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorPushpal Sidhu <psidhu@gateworks.com>2015-10-23 14:03:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:19:54 +0000
commit5cb4344e55d748483279a7f0035e7d581bcd52cf (patch)
treed06a44e2e5ae80f5d4b26914ef792926d147c8bd /meta/recipes-sato
parentbb5849423d7ed299b4c895a14d3754121ff68069 (diff)
downloadopenembedded-core-5cb4344e55d748483279a7f0035e7d581bcd52cf.tar.gz
webkitgtk: Add upstream patch to fix build problem
From Upstream webkit: fd15a368fa73fe08d91cc1dd7ef05c0c5a3ae851 Webkit will fail to compile under certain circumstances. Please see https://bugs.webkit.org/show_bug.cgi?id=149172 for more details. Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/files/0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch35
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.8.5.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/files/0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch b/meta/recipes-sato/webkit/files/0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch
new file mode 100644
index 0000000000..e95c0e4a22
--- /dev/null
+++ b/meta/recipes-sato/webkit/files/0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch
@@ -0,0 +1,35 @@
+From 6ea42d4fa6f3f6dd18c37cb7b6e1faea6afefba4 Mon Sep 17 00:00:00 2001
+From: "clopez@igalia.com" <clopez@igalia.com>
+Date: Tue, 15 Sep 2015 21:50:18 +0000
+Subject: [PATCH] [GTK] Build failure with ACCELERATED_2D_CANVAS when cairo-gl has
+ built with OpenGLESv2 support only.
+
+When cairo-gl is built with GLX and ACCELERATED_2D_CANVAS if cairo-gl was only
+built with OpenGLESv2, cairo-glx is not enabled causing
+Source/WebCore/platform/graphics/glx/GLContextGLX.cpp to reference an undeclared
+function and cause a compliation error. Adding an extra check resolves this
+build failure.
+
+Upstream-Status: Backport [webkit-2.10.0]
+
+Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
+---
+ Source/WebCore/platform/graphics/glx/GLContextGLX.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp b/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp
+index 7890d8d..4ed3a43 100644
+--- a/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp
++++ b/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp
+@@ -266,7 +266,7 @@ cairo_device_t* GLContextGLX::cairoDevice()
+ if (m_cairoDevice)
+ return m_cairoDevice;
+
+-#if ENABLE(ACCELERATED_2D_CANVAS)
++#if ENABLE(ACCELERATED_2D_CANVAS) && CAIRO_HAS_GLX_FUNCTIONS
+ m_cairoDevice = cairo_glx_device_create(sharedX11Display(), m_context);
+ #endif
+
+--
+2.6.2
+
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.8.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.8.5.bb
index e29666ae78..68634a9bc1 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.8.5.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.8.5.bb
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d842
SRC_URI = "\
http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://0001-This-patch-fixes-a-command-line-that-is-too-long-ove.patch \
+ file://0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch \
file://gcc5.patch \
"
SRC_URI[md5sum] = "df79991848a5096d3a75289ebce547ae"