summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-01-11 07:22:37 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:37:03 +0000
commit5a91224e9c6936ed76c3c27842b438b437e10bff (patch)
treeed7dbe1cdf84633ee196ed7036f53ac76da7163b /meta/recipes-sato
parent8327a9d2783e7a6209ea813295b9535653f0326e (diff)
downloadopenembedded-core-5a91224e9c6936ed76c3c27842b438b437e10bff.tar.gz
matchbox-desktop: fix build issue with gcc dso linking change
All the libraries needs to be specified explicitely with the new gcc dso linking change patch. This was causing build errors for this recipe. Specifying the libX11 library explicitely for linking to work without errors. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch26
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb5
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb5
3 files changed, 32 insertions, 4 deletions
diff --git a/meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch b/meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch
new file mode 100644
index 0000000000..54f3670e9b
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch
@@ -0,0 +1,26 @@
+after gcc linking has changed, all the libraries must be explicitely specified to for linking.
+This patch avoids this linking error:
+
+| make[2]: Entering directory `/disk0/pokybuild/build1/tmp/work/i586-poky-linux/matchbox-desktop-2.0+svnr2096-r0/matchbox-desktop-2/src'^M
+| ccache i586-poky-linux-gcc -march=i586 --sysroot=/disk0/pokybuild/build1/tmp/sysroots/i586-poky-linux -Wall -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb -feliminate-unused-debug-types -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -o matchbox-desktop main.o taku-category-bar.o desktop.o ../libtaku/libtaku.a -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -ldbus-1 -lpthread -lrt -lstartup-notification-1 ../libtaku/libinotify.a^M
+| /disk0/pokybuild/build1/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.5.1/ld: F^A: invalid DSO for symbol `XFree' definition^M
+| /disk0/pokybuild/build1/tmp/sysroots/i586-poky-linux/usr/lib/libX11.so.6: could not read symbols: Bad value^M
+| collect2: ld returned 1 exit status^M
+| make[2]: *** [matchbox-desktop] Error 1
+
+Nitin A Kamble <nitin.a.kamble@intel.com>
+Date: 2011/01/11
+
+Index: matchbox-desktop-2/configure.ac
+===================================================================
+--- matchbox-desktop-2.orig/configure.ac
++++ matchbox-desktop-2/configure.ac
+@@ -14,7 +14,7 @@ if test x$inotify_support = xyes; then
+ AC_DEFINE(WITH_INOTIFY, [1], [If inotify is enabled])
+ fi
+
+-PKG_CHECK_MODULES(GTK, gtk+-2.0)
++PKG_CHECK_MODULES(GTK, [gtk+-2.0 x11])
+
+ AC_ARG_ENABLE(startup_notification,
+ AC_HELP_STRING([--disable-startup-notification], [disable startup notification support]),
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb
index 83d4d0b3fd..2943e4d0ab 100644
--- a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb
@@ -2,9 +2,10 @@ DESCRIPTION = "Matchbox Window Manager Desktop"
LICENSE = "GPL"
DEPENDS = "gtk+ startup-notification"
SECTION = "x11/wm"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-desktop/2.0/matchbox-desktop-${PV}.tar.bz2"
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-desktop/2.0/matchbox-desktop-${PV}.tar.bz2 \
+ file://dso_linking_change_build_fix.patch"
EXTRA_OECONF = "--enable-startup-notification"
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb
index f5aadfd13b..bed82acee6 100644
--- a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb
@@ -11,9 +11,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
DEPENDS = "gtk+ startup-notification dbus"
SECTION = "x11/wm"
PV = "2.0+svnr${SRCPV}"
-PR = "r0"
+PR = "r1"
-SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN}-2;proto=http"
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN}-2;proto=http \
+ file://dso_linking_change_build_fix.patch"
EXTRA_OECONF = "--enable-startup-notification --with-dbus"