summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-05 12:34:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-06 11:23:36 +0100
commit94a1c0a15e57844feddad5607fb8643f7c956953 (patch)
tree9065be78f9dd69fb25795070a68218259cc4cd2c /meta/recipes-sato
parente9beba2a33b46d31bfdd926211d22ebf2abb6c90 (diff)
downloadopenembedded-core-94a1c0a15e57844feddad5607fb8643f7c956953.tar.gz
webkitgtk: Fix compile failures with clang
Backport upstream patch to address build regression with clang Fixes webkitgtk-2.24.3/Source/bmalloc/bmalloc/AvailableMemory.cpp:120:31: error: implicit instantiation of undefined template 'std::__1::array<char, 256>' std::array<char, 256> statmBuffer; ^ Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch33
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.24.3.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch b/meta/recipes-sato/webkit/webkitgtk/0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch
new file mode 100644
index 0000000000..e550a0d457
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch
@@ -0,0 +1,33 @@
+From 4bc241539246f7a17d07357257ab47cb96bc4b69 Mon Sep 17 00:00:00 2001
+From: "ysuzuki@apple.com" <ysuzuki@apple.com>
+Date: Thu, 18 Apr 2019 07:30:18 +0000
+Subject: [PATCH] Unreviewed, fix build failure
+ https://bugs.webkit.org/show_bug.cgi?id=195938
+
+Including <array>.
+
+* bmalloc/AvailableMemory.cpp:
+
+git-svn-id: http://svn.webkit.org/repository/webkit/trunk@244422 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+
+Upstream-Status: Backport [https://github.com/WebKit/webkit/commit/84c111dc0d83b5acf60706ef49bc2f5e91112471]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Source/bmalloc/bmalloc/AvailableMemory.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Source/bmalloc/bmalloc/AvailableMemory.cpp b/Source/bmalloc/bmalloc/AvailableMemory.cpp
+index 595889fe..b72000d5 100644
+--- a/Source/bmalloc/bmalloc/AvailableMemory.cpp
++++ b/Source/bmalloc/bmalloc/AvailableMemory.cpp
+@@ -32,6 +32,7 @@
+ #include "PerProcess.h"
+ #include "Scavenger.h"
+ #include "Sizes.h"
++#include <array>
+ #include <mutex>
+ #if BOS(DARWIN)
+ #if BPLATFORM(IOS_FAMILY)
+--
+2.22.0
+
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.24.3.bb b/meta/recipes-sato/webkit/webkitgtk_2.24.3.bb
index 81cbf34198..c42c3de69f 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.24.3.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.24.3.bb
@@ -23,6 +23,7 @@ SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://include_array.patch \
file://narrowing.patch \
file://0001-gstreamer-add-a-missing-format-string.patch \
+ file://0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch \
"
SRC_URI[md5sum] = "e2a5bbd09a217eba096a2d1562143e35"