summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-06-12 16:19:47 -0700
committerSaul Wold <sgw@linux.intel.com>2012-06-19 21:59:51 -0700
commitda10929059a4aba232d904d7a0d0a54715126c83 (patch)
treed710afdf0885407d6ab0120f68662f7330376eed /meta/recipes-support/db
parent959c20c99ac980764a99ed4db575e44917600736 (diff)
downloadopenembedded-core-da10929059a4aba232d904d7a0d0a54715126c83.tar.gz
db: Ensure the library version matches package version
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/db')
-rw-r--r--meta/recipes-support/db/db_5.3.15.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-support/db/db_5.3.15.bb b/meta/recipes-support/db/db_5.3.15.bb
index a34ad24a74..0df874e29b 100644
--- a/meta/recipes-support/db/db_5.3.15.bb
+++ b/meta/recipes-support/db/db_5.3.15.bb
@@ -45,15 +45,16 @@ B = "${WORKDIR}/db-${PV}/build_unix"
# The executables go in a separate package - typically there
# is no need to install these unless doing real database
# management on the system.
-PACKAGES += " ${PN}-bin"
+inherit lib_package
# Package contents
-FILES_${PN} = "${libdir}/libdb-5*so*"
FILES_${PN}-bin = "${bindir}/*"
# The dev package has the .so link (as in db3) and the .a's -
# it is therefore incompatible (cannot be installed at the
-# same time) as the db3 package, allow the default packaging
-# to sort out ${libdir}
+# same time) as the db3 package
+# sort out the .so since they do version prior to the .so
+SOLIBS = "-5*.so"
+FILES_SOLIBSDEV = "${libdir}/libdb.so"
#configuration - set in local.conf to override
# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)