summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme/0006-fix-build-path-issue.patch
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-02-01 01:17:10 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 10:54:38 +0000
commit80d2e065bb3e2ce7d7f8a956c3fecd26eb582b62 (patch)
treed87c537d2db165091c3ffa84fc0cb2ff13e62185 /meta/recipes-support/gpgme/gpgme/0006-fix-build-path-issue.patch
parentefa166021d2520b3badfdc44968ee618c65be705 (diff)
downloadopenembedded-core-80d2e065bb3e2ce7d7f8a956c3fecd26eb582b62.tar.gz
gpgme: 1.9.0 -> 1.10.0
1. Disable test at build time to workaround corss-compile Add 0007 to add option to disable python test and submit it to upstream 2. Rework patch 0002, since the following commit of upstream. https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commit;h=7309ce6f5f7c86570953a141965d4f54cd9ad9a0 3. Add patch 0006 to fix build path issue to improve reproducibility and submit it to upstream Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme/0006-fix-build-path-issue.patch')
-rw-r--r--meta/recipes-support/gpgme/gpgme/0006-fix-build-path-issue.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme/0006-fix-build-path-issue.patch b/meta/recipes-support/gpgme/gpgme/0006-fix-build-path-issue.patch
new file mode 100644
index 0000000000..8cc8983e27
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme/0006-fix-build-path-issue.patch
@@ -0,0 +1,37 @@
+From 180a5669e4a13a550b1b0dcef1689b6c0470fe54 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Wed, 31 Jan 2018 11:01:09 +0800
+Subject: [PATCH] fix build path issue
+
+Get the "--root" directory supplied to the "install" command,
+and use it as a prefix to strip off the purported filename
+encoded in bytecode files.
+
+Since --root added, we need to tweak --prefix and --install-lib
+to use relative path.
+
+Upstream-Status: Submitted [gnupg-devel@gnupg.org]
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ lang/python/Makefile.am | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/lang/python/Makefile.am b/lang/python/Makefile.am
+index ce4f0a5..5a468f1 100644
+--- a/lang/python/Makefile.am
++++ b/lang/python/Makefile.am
+@@ -90,8 +90,9 @@ install-exec-local:
+ build \
+ --build-base="$$(basename "$${PYTHON}")-gpg" \
+ install \
+- --prefix "$(DESTDIR)$(prefix)" \
+- --install-lib=$(DESTDIR)${pythondir} \
++ --root=${DESTDIR} \
++ --prefix "$(prefix)" \
++ --install-lib=${pythondir} \
+ --verbose ; \
+ done
+
+--
+1.8.3.1
+