summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libksba/libksba
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2012-12-03 18:17:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:35 +0000
commitd155ab2277c9ff2778f650a2acefee9b717e3d8f (patch)
tree3b941dc0bd4f51690877b577a0fe9a72cd3cb337 /meta/recipes-support/libksba/libksba
parent5bfc678aeb65b50710384e93b64add3a62146908 (diff)
downloadopenembedded-core-d155ab2277c9ff2778f650a2acefee9b717e3d8f.tar.gz
libksba: add pkgconfig support
Add pkgconfig support to libksba. [YOCTO #2453] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/libksba/libksba')
-rw-r--r--meta/recipes-support/libksba/libksba/ksba-add-pkgconfig-support.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-support/libksba/libksba/ksba-add-pkgconfig-support.patch b/meta/recipes-support/libksba/libksba/ksba-add-pkgconfig-support.patch
new file mode 100644
index 0000000000..fe1ec0ff2f
--- /dev/null
+++ b/meta/recipes-support/libksba/libksba/ksba-add-pkgconfig-support.patch
@@ -0,0 +1,59 @@
+Upstream-Status: Rejected
+
+Add pkgconfig support to libksba.
+This patch is rejected by upstream for the reason below:
+They think pkgconfig adds no portability and maintaining them is not worthwhile.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+
+Index: Makefile.am
+===============================================================
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -21,6 +21,9 @@
+ ACLOCAL_AMFLAGS = -I m4 -I gl/m4
+ AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
+
++pkgconfigdir = ${libdir}/pkgconfig
++pkgconfig_DATA = ksba.pc
++
+ # (A suitable gitlog-to-changelog script can be found in GnuPG master.)
+ GITLOG_TO_CHANGELOG=gitlog-to-changelog
+
+Index: configure.ac
+===============================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -399,6 +399,7 @@ m4/Makefile
+ gl/Makefile
+ src/Makefile
+ src/ksba-config
+ src/versioninfo.rc
++ksba.pc
+ tests/Makefile
+ doc/Makefile
+
+Index: src/ksba.pc.in
+===============================================================
+--- /dev/null
++++ b/ksba.pc.in
+@@ -0,0 +1,16 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++# API info
++api_version=@KSBA_CONFIG_API_VERSION@
++
++Name: ksba
++Description: Libksba provides an easy API to create and parse X.509 and CMS related objects
++Requires:
++Version: @VERSION@
++Libs: -L${libdir} -lksba
++Libs.private: -L{libdir} -lgpg-error
++Cflags: -I${includedir}
++
+--
+1.7.5.4
+