summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libproxy
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-02-08 12:34:40 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-11 12:27:27 +0000
commit30318b91a5a40bc4021c1a81381f292238f6d268 (patch)
tree691f20dd366a752c4927fb30501ec0a9d226309b /meta/recipes-support/libproxy
parentd44a2ec730fe52d2266c5e4d184cd4c881e172d1 (diff)
downloadopenembedded-core-30318b91a5a40bc4021c1a81381f292238f6d268.tar.gz
openembedded-core-30318b91a5a40bc4021c1a81381f292238f6d268.tar.bz2
openembedded-core-30318b91a5a40bc4021c1a81381f292238f6d268.zip
libproxy: replace PACKAGECONFIG equivalent with the real thing
No change in functionality, just use PACKAGECONFIG instead of python. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/libproxy')
-rw-r--r--meta/recipes-support/libproxy/libproxy_0.4.11.bb29
1 files changed, 19 insertions, 10 deletions
diff --git a/meta/recipes-support/libproxy/libproxy_0.4.11.bb b/meta/recipes-support/libproxy/libproxy_0.4.11.bb
index 9db52317bb..a5238573e7 100644
--- a/meta/recipes-support/libproxy/libproxy_0.4.11.bb
+++ b/meta/recipes-support/libproxy/libproxy_0.4.11.bb
@@ -6,29 +6,38 @@ LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
file://utils/proxy.c;beginline=1;endline=18;md5=55152a1006d7dafbef32baf9c30a99c0"
-DEPENDS = "gconf glib-2.0"
+DEPENDS = "glib-2.0"
SRC_URI = "${DEBIAN_MIRROR}/main/libp/${BPN}/${BPN}_${PV}.orig.tar.gz \
file://0001-test-Include-sys-select.h-for-select.patch \
"
+
SRC_URI[md5sum] = "3cd1ae2a4abecf44b3f24d6639d2cd84"
SRC_URI[sha256sum] = "dc3f33de54163718f82b3e7c496a7de97f8862578414b8ecaad3cbfe4821864b"
inherit cmake pkgconfig
-EXTRA_OECMAKE = "-DWITH_WEBKIT=no -DWITH_GNOME=yes -DWITH_KDE4=no \
- -DWITH_PYTHON=no -DWITH_PERL=no -DWITH_MOZJS=no -DWITH_NM=no -DLIB_INSTALL_DIR=${libdir} -DLIBEXEC_INSTALL_DIR=${libexecdir}"
+PACKAGECONFIG ?= " \
+ ${@ '' if incompatible_license_contains('GPLv3', 'x', '', d) == 'x' or bb.utils.contains('DISTRO_FEATURES', 'x11', 'x', '', d) == '' else 'gnome' } \
+"
-FILES_${PN} += "${libdir}/${BPN}/${PV}/modules"
-FILES_${PN}-dev += "${datadir}/cmake"
+PACKAGECONFIG[gnome] = "-DWITH_GNOME=yes,-DWITH_GNOME=no,gconf"
+
+EXTRA_OECMAKE += " \
+ -DWITH_KDE4=no \
+ -DWITH_MOZJS=no \
+ -DWITH_NM=no \
+ -DWITH_PERL=no \
+ -DWITH_PYTHON=no \
+ -DWITH_WEBKIT=no \
+ -DLIB_INSTALL_DIR=${libdir} \
+ -DLIBEXEC_INSTALL_DIR=${libexecdir} \
+"
do_configure_prepend() {
export HOST_SYS=${HOST_SYS}
export BUILD_SYS=${BUILD_SYS}
}
-python() {
- if incompatible_license_contains("GPLv3", "x", "", d) == "x" or bb.utils.contains("DISTRO_FEATURES", "x11", "x", "", d) == "":
- d.setVar("EXTRA_OECMAKE", d.getVar("EXTRA_OECMAKE", False).replace("-DWITH_GNOME=yes", "-DWITH_GNOME=no"))
- d.setVar("DEPENDS", " ".join(i for i in d.getVar("DEPENDS", False).split() if i != "gconf"))
-}
+FILES_${PN} += "${libdir}/${BPN}/${PV}/modules"
+FILES_${PN}-dev += "${datadir}/cmake"