summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libproxy
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-12-15 17:03:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-19 17:54:14 +0000
commit97f46c97c7f8a39f3691aee423b4192680d114a0 (patch)
treef41066f111715b4f7f24c7cc9e59f16f62f08b09 /meta/recipes-support/libproxy
parentfddca246f15ff72828a0198d8c4d3e58d8bf4442 (diff)
downloadopenembedded-core-97f46c97c7f8a39f3691aee423b4192680d114a0.tar.gz
openembedded-core-97f46c97c7f8a39f3691aee423b4192680d114a0.tar.bz2
openembedded-core-97f46c97c7f8a39f3691aee423b4192680d114a0.zip
libproxy: let INCOMPATIBLE_LICENSE supports wildcard
While wildcard in INCOMPATIBLE_LICENSE, such as INCOMPATIBLE_LICENSE = "*GPL-3", libproxy could correct work. [YOCTO #5592] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Diffstat (limited to 'meta/recipes-support/libproxy')
-rw-r--r--meta/recipes-support/libproxy/libproxy_0.4.11.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/libproxy/libproxy_0.4.11.bb b/meta/recipes-support/libproxy/libproxy_0.4.11.bb
index a53a197615..3367c85156 100644
--- a/meta/recipes-support/libproxy/libproxy_0.4.11.bb
+++ b/meta/recipes-support/libproxy/libproxy_0.4.11.bb
@@ -29,7 +29,7 @@ do_configure_prepend() {
}
python() {
- if bb.utils.contains("INCOMPATIBLE_LICENSE", "GPLv3", "x", "", d) == "x" or bb.utils.contains("DISTRO_FEATURES", "x11", "x", "", d) == "":
+ if incompatible_license_contains("GPLv3", "x", "", d) == "x" or bb.utils.contains("DISTRO_FEATURES", "x11", "x", "", d) == "":
d.setVar("EXTRA_OECMAKE", d.getVar("EXTRA_OECMAKE").replace("-DWITH_GNOME=yes", "-DWITH_GNOME=no"))
d.setVar("DEPENDS", " ".join(i for i in d.getVar("DEPENDS").split() if i != "gconf"))
}