summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libunwind
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-12-13 20:09:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:34:32 +0000
commitcdd6130255d8fc78b0a43fad410cde024cb1b9a5 (patch)
tree89fd8bb8ef7dad70057fc72c6d7f0c5fe7d6c0dd /meta/recipes-support/libunwind
parentd9dca61ed26af166df913f34bdce3f2830682b33 (diff)
downloadopenembedded-core-cdd6130255d8fc78b0a43fad410cde024cb1b9a5.tar.gz
libunwind: apply a patch to fix x32
Apply patch to fix the X32 build from https://github.com/sjnewbury/x32 Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/libunwind')
-rw-r--r--meta/recipes-support/libunwind/libunwind/libunwind-1.1-x32.patch31
-rw-r--r--meta/recipes-support/libunwind/libunwind_git.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/libunwind/libunwind/libunwind-1.1-x32.patch b/meta/recipes-support/libunwind/libunwind/libunwind-1.1-x32.patch
new file mode 100644
index 0000000000..32516464cd
--- /dev/null
+++ b/meta/recipes-support/libunwind/libunwind/libunwind-1.1-x32.patch
@@ -0,0 +1,31 @@
+From 506bd37bd580d7382d7c58257dac4b1e502a887c Mon Sep 17 00:00:00 2001
+From: Christopher Larson <chris_larson@mentor.com>
+Date: Tue, 13 Dec 2016 09:50:34 -0700
+Subject: [PATCH] Fix for X32
+
+Apply patch to fix the X32 build from https://github.com/sjnewbury/x32.
+
+Upstream-Status: Pending
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+---
+ src/x86_64/Gos-linux.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/x86_64/Gos-linux.c b/src/x86_64/Gos-linux.c
+index 9e1acfc..8169d5a 100644
+--- a/src/x86_64/Gos-linux.c
++++ b/src/x86_64/Gos-linux.c
+@@ -143,8 +143,8 @@ x86_64_sigreturn (unw_cursor_t *cursor)
+
+ Debug (8, "resuming at ip=%llx via sigreturn(%p)\n",
+ (unsigned long long) c->dwarf.ip, sc);
+- __asm__ __volatile__ ("mov %0, %%rsp;"
+- "mov %1, %%rax;"
++ __asm__ __volatile__ ("mov %q0, %%rsp;"
++ "mov %q1, %%rax;"
+ "syscall"
+ :: "r"(sc), "i"(SYS_rt_sigreturn)
+ : "memory");
+--
+2.8.0
+
diff --git a/meta/recipes-support/libunwind/libunwind_git.bb b/meta/recipes-support/libunwind/libunwind_git.bb
index 424943087e..b637c5c448 100644
--- a/meta/recipes-support/libunwind/libunwind_git.bb
+++ b/meta/recipes-support/libunwind/libunwind_git.bb
@@ -11,6 +11,7 @@ SRC_URI = "git://git.sv.gnu.org/libunwind.git \
file://0001-Fix-build-on-mips-musl.patch \
file://0001-add-knobs-to-disable-enable-tests.patch \
file://0001-ppc32-Consider-ucontext-mismatches-between-glibc-and.patch \
+ file://libunwind-1.1-x32.patch \
"
SRC_URI_append_libc-musl = " file://musl-header-conflict.patch"