summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libusb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-11-13 14:41:53 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:48:19 +0000
commitcbdd4099b06011f2b73743c715276c730b7bf576 (patch)
tree5d3f4ae19ddb16b1358184ad0f89fe72634bbbe2 /meta/recipes-support/libusb
parent641a9454fbb25f1458bb8f96cbfada3e0da98dee (diff)
downloadopenembedded-core-cbdd4099b06011f2b73743c715276c730b7bf576.tar.gz
libusb1: fix make install race
There's an install race in when building in parallel, remove a redundant rule to stop it happening. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/libusb')
-rw-r--r--meta/recipes-support/libusb/libusb1/no-dll.patch19
-rw-r--r--meta/recipes-support/libusb/libusb1_1.0.20.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-support/libusb/libusb1/no-dll.patch b/meta/recipes-support/libusb/libusb1/no-dll.patch
new file mode 100644
index 0000000000..6e6bb83d1f
--- /dev/null
+++ b/meta/recipes-support/libusb/libusb1/no-dll.patch
@@ -0,0 +1,19 @@
+As all invokes all-recursive which uses sub-makes to invoke all-am, the
+resulting makefile wants to build libusb-1.0.la twice. In non-parallel builds
+the second attempt is skipped as the target already exists, but in highly
+parallel builds it's likely that two makes will be building libusb-1.0.la at the
+same time.
+
+Solve this by removing the explicit all target, which as libusb-1.0.dll isn't
+built under Linux is redundant anyway.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/libusb/Makefile.am b/libusb/Makefile.am
+index 0cab0a0..c880213 100644
+--- a/libusb/Makefile.am
++++ b/libusb/Makefile.am
+@@ -1,2 +0,0 @@
+-all: libusb-1.0.la libusb-1.0.dll
+-
diff --git a/meta/recipes-support/libusb/libusb1_1.0.20.bb b/meta/recipes-support/libusb/libusb1_1.0.20.bb
index 21b8b45a6a..4cad2d4be7 100644
--- a/meta/recipes-support/libusb/libusb1_1.0.20.bb
+++ b/meta/recipes-support/libusb/libusb1_1.0.20.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
BBCLASSEXTEND = "native nativesdk"
SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2 \
+ file://no-dll.patch \
"
SRC_URI[md5sum] = "1d4eb194eaaa2bcfbba28102768c7dbf"