summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nettle
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2019-04-24 16:41:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-29 22:29:19 +0100
commit524fcf34128045f9f5726a1f1b8715a12b12ae7c (patch)
treebc6d412b2251c1a309821813ac6e0683f45f8732 /meta/recipes-support/nettle
parent91359a91b8c89dc5e1f3a946137204156c47a3af (diff)
downloadopenembedded-core-524fcf34128045f9f5726a1f1b8715a12b12ae7c.tar.gz
nettle: fix ptest failure
Rework dlopen-test.patch to fix below dlopen-test failure: # cd /usr/lib64/nettle/ptest # ./run-ptest dlopen failed: /usr/lib/libnettle.so: cannot open shared object file: No such file or directory ./run-ptest: line 8: 7607 Aborted "./$f" FAIL: dlopen-test As the test dlopen-test depends on libnettle.so which belongs to nettle-dev package, so add it to rdepends of nettle-ptest. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/nettle')
-rw-r--r--meta/recipes-support/nettle/nettle-3.4.1/dlopen-test.patch5
-rw-r--r--meta/recipes-support/nettle/nettle_3.4.1.bb3
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-support/nettle/nettle-3.4.1/dlopen-test.patch b/meta/recipes-support/nettle/nettle-3.4.1/dlopen-test.patch
index c4f0b7ea1c..fea5774206 100644
--- a/meta/recipes-support/nettle/nettle-3.4.1/dlopen-test.patch
+++ b/meta/recipes-support/nettle/nettle-3.4.1/dlopen-test.patch
@@ -1,4 +1,4 @@
-Replace relative path of libnettle.so with absolute path so the test
+Remove the relative path for libnettle.so so the test
program can find it.
Relative paths are not suitable, as the folder strucure for ptest
is different from the one expected by the nettle testsuite.
@@ -6,6 +6,7 @@ is different from the one expected by the nettle testsuite.
Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
--- a/testsuite/dlopen-test.c 2016-10-01 00:28:38.000000000 -0700
+++ b/testsuite/dlopen-test.c 2017-10-13 11:08:57.227572860 -0700
@@ -14,7 +15,7 @@ Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
{
#if HAVE_LIBDL
- void *handle = dlopen ("../libnettle.so", RTLD_NOW);
-+ void *handle = dlopen ("/usr/lib/libnettle.so", RTLD_NOW);
++ void *handle = dlopen ("libnettle.so", RTLD_NOW);
int (*get_version)(void);
if (!handle)
{
diff --git a/meta/recipes-support/nettle/nettle_3.4.1.bb b/meta/recipes-support/nettle/nettle_3.4.1.bb
index 8375fcf2df..cd8024f793 100644
--- a/meta/recipes-support/nettle/nettle_3.4.1.bb
+++ b/meta/recipes-support/nettle/nettle_3.4.1.bb
@@ -49,4 +49,7 @@ do_install_ptest() {
install ${B}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
}
+RDEPENDS_${PN}-ptest += "${PN}-dev"
+INSANE_SKIP_${PN}-ptest += "dev-deps"
+
BBCLASSEXTEND = "native nativesdk"