summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nspr
diff options
context:
space:
mode:
authorNikolay Merinov <n.merinov@inango-systems.com>2017-10-05 12:25:39 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-10-06 12:03:34 +0100
commit79e3339ab9edacb9e34d3725305d5880a974364a (patch)
treec2f8150d54dac8f30b0234f1f7fb5f70090f906e /meta/recipes-support/nspr
parent74ef87b31e33436e82f4985fa99b570726a5e564 (diff)
downloadopenembedded-core-79e3339ab9edacb9e34d3725305d5880a974364a.tar.gz
nspr, nss: Use BUILD_CC instead of hardcoded "gcc"
Recipes nspr_4.16.bb and nss_3.31.1.bb ignored BUILD_CC and it's BUILD_CFLAGS and tried to compile with hardcoded "gcc" instead. As result build for this recipes will fail if host use different name for compiler or require any flags. Signed-off-by: Nikolay Merinov <n.merinov@inango-systems.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/nspr')
-rw-r--r--meta/recipes-support/nspr/nspr_4.16.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/nspr/nspr_4.16.bb b/meta/recipes-support/nspr/nspr_4.16.bb
index bb178fe712..78ef994ffd 100644
--- a/meta/recipes-support/nspr/nspr_4.16.bb
+++ b/meta/recipes-support/nspr/nspr_4.16.bb
@@ -155,7 +155,7 @@ PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
do_compile_prepend() {
- oe_runmake CROSS_COMPILE=1 CFLAGS="-DXP_UNIX" LDFLAGS="" CC=gcc -C config export
+ oe_runmake CROSS_COMPILE=1 CFLAGS="-DXP_UNIX ${BUILD_CFLAGS}" LDFLAGS="" CC="${BUILD_CC}" -C config export
}
do_compile_append() {