summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/p11-kit/p11-kit_0.23.21.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-09-02 23:13:19 +0200
committerSteve Sakoman <steve@sakoman.com>2021-02-11 04:27:21 -1000
commitf28b3af0c7011f9c9e4d463b5d4cc6552321a9af (patch)
treecee0b94053da40d2b1612739d839b3ccfc15914e /meta/recipes-support/p11-kit/p11-kit_0.23.21.bb
parentb33b4f318e66b050bea93d5c3e324bbeb81642d7 (diff)
downloadopenembedded-core-f28b3af0c7011f9c9e4d463b5d4cc6552321a9af.tar.gz
p11-kit: upgrade 0.23.20 -> 0.23.21
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 6e811db2f614500f16415fc09801f229968428e7) [0.23.x is an lts release, bug fix only update] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-support/p11-kit/p11-kit_0.23.21.bb')
-rw-r--r--meta/recipes-support/p11-kit/p11-kit_0.23.21.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/p11-kit/p11-kit_0.23.21.bb b/meta/recipes-support/p11-kit/p11-kit_0.23.21.bb
new file mode 100644
index 0000000000..b1fd2334b2
--- /dev/null
+++ b/meta/recipes-support/p11-kit/p11-kit_0.23.21.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
+
+inherit meson gettext pkgconfig gtk-doc bash-completion
+
+DEPENDS = "libtasn1 libtasn1-native libffi"
+
+DEPENDS_append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
+
+SRC_URI = "git://github.com/p11-glue/p11-kit"
+SRCREV = "fd8b56f3ee971f94dc6fc95411fc01e1c12153ab"
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates"
+
+GTKDOC_MESON_OPTION = 'gtk_doc'
+
+FILES_${PN} += " \
+ ${libdir}/p11-kit-proxy.so \
+ ${libdir}/pkcs11/*.so \
+ ${libdir}/pkcs11/*.la \
+ ${systemd_user_unitdir}/*"
+
+# PN contains p11-kit-proxy.so, a symlink to a loadable module
+INSANE_SKIP_${PN} = "dev-so"
+
+BBCLASSEXTEND = "nativesdk"