summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/sqlite
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-01-13 12:46:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-17 11:32:20 +0000
commited46ac71846845ffc41efcd55a36e27883d9980a (patch)
treeb34436977972e754ea60d95a6f340f66d1db5fcb /meta/recipes-support/sqlite
parentdd329d28ab3f47c8b03563e88703f6b1c09ce72b (diff)
downloadopenembedded-core-ed46ac71846845ffc41efcd55a36e27883d9980a.tar.gz
sqlite3: upgrade to version 3.10.0
3.9.2 -> 3.10.0 1. Fixed a parallel build problem 2. Added a PACKAGECONFIG for readline Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/sqlite')
-rw-r--r--meta/recipes-support/sqlite/sqlite3.inc2
-rw-r--r--meta/recipes-support/sqlite/sqlite3/parallel.patch24
-rw-r--r--meta/recipes-support/sqlite/sqlite3_3.10.0.bb (renamed from meta/recipes-support/sqlite/sqlite3_3.9.2.bb)8
3 files changed, 31 insertions, 3 deletions
diff --git a/meta/recipes-support/sqlite/sqlite3.inc b/meta/recipes-support/sqlite/sqlite3.inc
index 2e3791bfc3..5eb5de3b01 100644
--- a/meta/recipes-support/sqlite/sqlite3.inc
+++ b/meta/recipes-support/sqlite/sqlite3.inc
@@ -9,6 +9,8 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--enable-shared --enable-threadsafe"
EXTRA_OECONF_class-native = "--enable-shared --enable-threadsafe --disable-readline"
+PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
+
export config_BUILD_CC = "${BUILD_CC}"
export config_BUILD_CFLAGS = "${BUILD_CFLAGS}"
export config_BUILD_LIBS = "${BUILD_LDFLAGS}"
diff --git a/meta/recipes-support/sqlite/sqlite3/parallel.patch b/meta/recipes-support/sqlite/sqlite3/parallel.patch
new file mode 100644
index 0000000000..87471f0615
--- /dev/null
+++ b/meta/recipes-support/sqlite/sqlite3/parallel.patch
@@ -0,0 +1,24 @@
+build: Fix parallel build problems
+
+Avoid parallel build errors related to sqlite3.o target.
+
+Upstream-Status: Pending
+
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
+---
+diff -Naur sqlite-autoconf-3100000-orig/Makefile.am sqlite-autoconf-3100000/Makefile.am
+--- sqlite-autoconf-3100000-orig/Makefile.am 2016-01-06 14:03:00.000000000 +0200
++++ sqlite-autoconf-3100000/Makefile.am 2016-01-12 13:14:03.620117514 +0200
+@@ -6,10 +6,8 @@
+ libsqlite3_la_LDFLAGS = -no-undefined -version-info 8:6:8
+
+ bin_PROGRAMS = sqlite3
+-sqlite3_SOURCES = shell.c sqlite3.h
+-EXTRA_sqlite3_SOURCES = sqlite3.c
+-sqlite3_LDADD = @EXTRA_SHELL_OBJ@ @READLINE_LIBS@
+-sqlite3_DEPENDENCIES = @EXTRA_SHELL_OBJ@
++sqlite3_SOURCES = shell.c sqlite3.c sqlite3.h
++sqlite3_LDADD = @READLINE_LIBS@
+ sqlite3_CFLAGS = $(AM_CFLAGS)
+
+ include_HEADERS = sqlite3.h sqlite3ext.h
diff --git a/meta/recipes-support/sqlite/sqlite3_3.9.2.bb b/meta/recipes-support/sqlite/sqlite3_3.10.0.bb
index 18b1a2b57d..092f78266f 100644
--- a/meta/recipes-support/sqlite/sqlite3_3.9.2.bb
+++ b/meta/recipes-support/sqlite/sqlite3_3.10.0.bb
@@ -10,10 +10,12 @@ def sqlite_download_version(d):
PE = "3"
SQLITE_PV = "${@sqlite_download_version(d)}"
-SRC_URI = "http://www.sqlite.org/2015/sqlite-autoconf-${SQLITE_PV}.tar.gz"
+SRC_URI = "http://www.sqlite.org/2016/sqlite-autoconf-${SQLITE_PV}.tar.gz \
+ file://parallel.patch \
+ "
-SRC_URI[md5sum] = "bc4eb5b3fc5cfcb6e059794306cac1ca"
-SRC_URI[sha256sum] = "064c0abe9c9177534d4c770bca7a5902f9924b629ac886b4c08956be6dfbc36b"
+SRC_URI[md5sum] = "274364e6ca5c1104d42912f11e61ed26"
+SRC_URI[sha256sum] = "43cc292d70711fa7580250c8a1cd7c64813a4a0a479dbd502cce5f10b5d91042"
UPSTREAM_CHECK_URI = "http://www.sqlite.org/"
UPSTREAM_CHECK_REGEX = "releaselog/(?P<pver>(\d+[\.\-_]*)+)\.html"