summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vim/files
diff options
context:
space:
mode:
authorJoe Slater <joe.slater@windriver.com>2020-04-15 14:28:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-24 14:07:54 +0100
commit8972fe5581b9fe8ef14d539001758bb13bca6737 (patch)
tree6be7a189963fd79f8b22907416d10d8a9b945892 /meta/recipes-support/vim/files
parente694b09cacf8eb0b7e189f449816d3d6a337cb37 (diff)
downloadopenembedded-core-8972fe5581b9fe8ef14d539001758bb13bca6737.tar.gz
vim: do not adjust script paths building for target
When cross-compiling, do not change scripts to use host versions of perl and gawk. Also, use INSANE_SKIP to suppress QA complaints if perl or gawk are not on the target. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/vim/files')
-rw-r--r--meta/recipes-support/vim/files/no-path-adjust.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/vim/files/no-path-adjust.patch b/meta/recipes-support/vim/files/no-path-adjust.patch
new file mode 100644
index 0000000000..05c2d803f6
--- /dev/null
+++ b/meta/recipes-support/vim/files/no-path-adjust.patch
@@ -0,0 +1,27 @@
+vim: do not adjust script pathnames
+
+When cross-compiling, we do not want to reference the host versions of
+things like perl and awk.
+
+Upstream-Status: Pending
+
+Signed-off-by: Joe Slater <joe.slater@windriver.com>
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -2507,11 +2507,14 @@ installtools: $(TOOLS) $(DESTDIR)$(exec_
+ rm -rf $$cvs; \
+ fi
+ -chmod $(FILEMOD) $(DEST_TOOLS)/*
+-# replace the path in some tools
++
++# replace the path in some tools, but not when cross-compiling
++ifneq ($(CROSS_COMPILING),1)
+ perlpath=`./which.sh perl` && sed -e "s+/usr/bin/perl+$$perlpath+" $(TOOLSSOURCE)/efm_perl.pl >$(DEST_TOOLS)/efm_perl.pl
+ awkpath=`./which.sh nawk` && sed -e "s+/usr/bin/nawk+$$awkpath+" $(TOOLSSOURCE)/mve.awk >$(DEST_TOOLS)/mve.awk; if test -z "$$awkpath"; then \
+ awkpath=`./which.sh gawk` && sed -e "s+/usr/bin/nawk+$$awkpath+" $(TOOLSSOURCE)/mve.awk >$(DEST_TOOLS)/mve.awk; if test -z "$$awkpath"; then \
+ awkpath=`./which.sh awk` && sed -e "s+/usr/bin/nawk+$$awkpath+" $(TOOLSSOURCE)/mve.awk >$(DEST_TOOLS)/mve.awk; fi; fi
++endif
+ -chmod $(SCRIPTMOD) `grep -l "^#!" $(DEST_TOOLS)/*`
+
+ # install the language specific files for tools, if they were unpacked