aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 13:08:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-19 12:24:05 +0100
commit7d674820958be3a7051ea619effe1a6061d9cbe2 (patch)
tree5ca9163652717746c8c79a88dbd0bcb047eea558 /meta/recipes-support
parentca30b6587841f5e9a42aaedb8e0b89ff5a4a6a37 (diff)
downloadopenembedded-core-7d674820958be3a7051ea619effe1a6061d9cbe2.tar.gz
Remove a number of unneeded import os/bb calls
The bb and os modules are always imported so having these extra import calls are a waste of space/execution time. They also set a bad example for people copy and pasting code so clean them up. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/boost/boost.inc2
-rw-r--r--meta/recipes-support/pth/pth_2.0.7.bb2
2 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-support/boost/boost.inc b/meta/recipes-support/boost/boost.inc
index 1162ccd5fb..ec602a6cf4 100644
--- a/meta/recipes-support/boost/boost.inc
+++ b/meta/recipes-support/boost/boost.inc
@@ -47,8 +47,6 @@ BOOST_LIBS = "\
# Make a package for each library, plus -dev
PACKAGES = "${PN}-dbg ${BOOST_PACKAGES}"
python __anonymous () {
- import bb
-
packages = []
extras = []
for lib in d.getVar('BOOST_LIBS', True).split( ):
diff --git a/meta/recipes-support/pth/pth_2.0.7.bb b/meta/recipes-support/pth/pth_2.0.7.bb
index 2aeec440cc..83a03b334f 100644
--- a/meta/recipes-support/pth/pth_2.0.7.bb
+++ b/meta/recipes-support/pth/pth_2.0.7.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=12;endline=15;md5=a48af114a80c222ca
PR = "r2"
python __anonymous () {
- import bb, re
+ import re
uc_os = (re.match('.*uclibc*', d.getVar('TARGET_OS', True)) != None)
if uc_os:
raise bb.parse.SkipPackage("incompatible with uClibc")