summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-03-18 11:33:10 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-18 23:18:03 +0000
commit4e592efe8c5ff918a77f7b7b2c17a6b698b1dd68 (patch)
tree0bdd04ea91c462f3371ff24ae54a18752225f1f2 /meta/recipes-support
parent5188687660f5aa37014aac50c43e141f032455d7 (diff)
downloadopenembedded-core-4e592efe8c5ff918a77f7b7b2c17a6b698b1dd68.tar.gz
db: Fix path of arm-thumb patch
Newer versions of patch, such as in Fedora 14, don't like ".." within the middle of the file to be patched path. In order to fix the issue we have to hand apply the patch instead of using the normal mechanisms. Only flaw with the os.system(...) approach is if it fails we don't get any notification or a resolver failure. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/db/db/arm-thumb-mutex_db5.patch4
-rw-r--r--meta/recipes-support/db/db_5.1.19.bb9
2 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-support/db/db/arm-thumb-mutex_db5.patch b/meta/recipes-support/db/db/arm-thumb-mutex_db5.patch
index 37d0d93abd..51d485499e 100644
--- a/meta/recipes-support/db/db/arm-thumb-mutex_db5.patch
+++ b/meta/recipes-support/db/db/arm-thumb-mutex_db5.patch
@@ -1,5 +1,5 @@
---- db-5.1.19/../src/dbinc/mutex_int.h.orig 2011-01-05 19:21:42.181805366 -0600
-+++ db-5.1.19/../src/dbinc/mutex_int.h 2011-01-05 19:24:53.141853117 -0600
+--- db-5.1.19/src/dbinc/mutex_int.h.orig 2011-01-05 19:21:42.181805366 -0600
++++ db-5.1.19/src/dbinc/mutex_int.h 2011-01-05 19:24:53.141853117 -0600
@@ -474,6 +474,25 @@
#ifdef LOAD_ACTUAL_MUTEX_CODE
diff --git a/meta/recipes-support/db/db_5.1.19.bb b/meta/recipes-support/db/db_5.1.19.bb
index 919e532be1..94ce180cf9 100644
--- a/meta/recipes-support/db/db_5.1.19.bb
+++ b/meta/recipes-support/db/db_5.1.19.bb
@@ -14,11 +14,10 @@ HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
LICENSE = "BSD Sleepycat"
VIRTUAL_NAME ?= "virtual/db"
CONFLICTS = "db3"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
-#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
-SRC_URI += "file://arm-thumb-mutex_db5.patch;patch=1"
+SRC_URI += "file://arm-thumb-mutex_db5.patch;apply=no"
SRC_URI[md5sum] = "76fcbfeebfcd09ba0b4d96bfdf8d884d"
SRC_URI[sha256sum] = "0194d4ca9266ba1a1c0bfbc233b18bfd05f63163453c81ebcdfdc7112d5ac850"
@@ -80,6 +79,10 @@ do_configure() {
oe_runconf
}
+do_patch_append() {
+ os.system("cd ${S}/.. ; patch -p1 -i ${WORKDIR}/arm-thumb-mutex_db5.patch")
+}
+
do_install_append() {
mkdir -p ${D}/${includedir}/db51
#mv ${D}/${includedir}/db_185.h ${D}/${includedir}/db51/.