summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-09-30 12:21:23 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-14 12:53:30 +0100
commit7bec22c70598a5180f754bbbe2dfdd3db2843a64 (patch)
tree5410b6e952d075cdae0951e6458e8b86ab8d8413 /meta/recipes-support
parent26135858692b591f82deaaa2c22d27ab02750c53 (diff)
downloadopenembedded-core-7bec22c70598a5180f754bbbe2dfdd3db2843a64.tar.gz
libnl2: Fix a race on route/pktloc_syntax.h
At issue is that route/pktloc.c (not generated) depends on route/pktloc_syntax.h (generated). Signed-off-by: Tom Rini <tom_rini@mentor.com> Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libnl/fix-pktloc_syntax_h-race.patch26
-rw-r--r--meta/recipes-support/libnl/libnl_2.0.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/meta/recipes-support/libnl/fix-pktloc_syntax_h-race.patch b/meta/recipes-support/libnl/fix-pktloc_syntax_h-race.patch
new file mode 100644
index 0000000000..05d75dbaf3
--- /dev/null
+++ b/meta/recipes-support/libnl/fix-pktloc_syntax_h-race.patch
@@ -0,0 +1,26 @@
+Upstream-Status: Inappropriate [configuration]
+
+libnl has progressed to 0.3.2 and there does not appear to be any
+"make -j" issues with this build after my limited testing on that
+newer version so we can assume this issue is fixed upstream
+
+Index: libnl-2.0/lib/Makefile.am
+===================================================================
+--- libnl-2.0.orig/lib/Makefile.am
++++ libnl-2.0/lib/Makefile.am
+@@ -27,11 +27,15 @@ CLEANFILES = \
+ route/pktloc_grammar.c route/pktloc_grammar.h \
+ route/pktloc_syntax.c route/pktloc_syntax.h
+
++BUILT_SOURCES = route/pktloc_syntax.h route/pktloc_grammar.h
++
+ # Hack to avoid using ylwrap. It does not function correctly in combination
+ # with --header-file=
++route/pktloc_grammar.h: route/pktloc_grammar.c
+ route/pktloc_grammar.c: route/pktloc_grammar.l
+ $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+
++route/pktloc_syntax.h: route/pktloc_syntax.c
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+ $(YACC) -d $(YFLAGS) -o $@ $^
+
diff --git a/meta/recipes-support/libnl/libnl_2.0.bb b/meta/recipes-support/libnl/libnl_2.0.bb
index 0dfcaf63a7..5339846599 100644
--- a/meta/recipes-support/libnl/libnl_2.0.bb
+++ b/meta/recipes-support/libnl/libnl_2.0.bb
@@ -6,10 +6,11 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=2b41e13261a330ee784153ecbb6a82bc"
DEPENDS = "flex-native bison-native"
-PR = "r2"
+PR = "r3"
SRC_URI= "http://www.infradead.org/~tgr/libnl/files/${BPN}-${PV}.tar.gz \
file://fix-makefile.patch \
+ file://fix-pktloc_syntax_h-race.patch \
"
SRC_URI[md5sum] = "6aaf1e9802a17a7d702bb0638044ffa7"