summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorDouglas Royds <douglas.royds@taitradio.com>2018-11-29 10:13:18 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-03 12:19:42 +0000
commit800953bcd4ce9c4e4f768bc0de504b91d5be99cb (patch)
tree21455023d72c2d97968e1520153c902d1b741201 /meta/recipes-support
parentdf65ec47a8743aab2e06f920539a6d79b2d65b54 (diff)
downloadopenembedded-core-800953bcd4ce9c4e4f768bc0de504b91d5be99cb.tar.gz
acl: Strip build host tool details from installed ptest file
Adopt the PTEST_BUILD_HOST_FILES mechanism to strip build host paths from the installed builddefs file. Also strip the record of the build host rpm version. Signed-off-by: Douglas Royds <douglas.royds@taitradio.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/attr/acl_2.2.52.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-support/attr/acl_2.2.52.bb b/meta/recipes-support/attr/acl_2.2.52.bb
index 318308a009..6bc77d868d 100644
--- a/meta/recipes-support/attr/acl_2.2.52.bb
+++ b/meta/recipes-support/attr/acl_2.2.52.bb
@@ -39,15 +39,12 @@ do_install_append() {
inherit ptest
+PTEST_BUILD_HOST_FILES = "builddefs"
+PTEST_BUILD_HOST_PATTERN = "^RPM"
do_install_ptest() {
tar -c --exclude=nfs test/ | ( cd ${D}${PTEST_PATH} && tar -xf - )
install -d ${D}${PTEST_PATH}/include
install -m 644 ${S}/include/builddefs ${S}/include/buildmacros ${S}/include/buildrules ${D}${PTEST_PATH}/include/
- # Remove any build host references
- sed -e "s:--sysroot=${STAGING_DIR_TARGET}::g" \
- -e 's:${HOSTTOOLS_DIR}/::g' \
- -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
- -i ${D}${PTEST_PATH}/include/builddefs
}
RDEPENDS_${PN}-ptest = "acl bash coreutils perl perl-module-filehandle perl-module-getopt-std perl-module-posix shadow"