summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-05-08 15:40:18 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-11 07:49:31 +0100
commitb46c55c3b9db5d8f2080ae2611294a5b24efe4a4 (patch)
tree113c048f00981f0feaf8bbe4f395ddfeb383e437 /meta/recipes-support
parent06aaafd14f3c8e27faeea0a514f80e1ff5eb4deb (diff)
downloadopenembedded-core-b46c55c3b9db5d8f2080ae2611294a5b24efe4a4.tar.gz
libcap: fix -native and usrmerge builds
When attempting to build a -native package which DEPENDS on libcap-native the libcap libraries are not found and the build will fail (for example attempting to build qemu-native with 'PACKAGECONFIG_append = " virtfs"'). It turns out commit 2c9c4a406a0f [libcap: fix (base_)libdir usage] breaks builds of libcap(-native) when $root_prefix is not "". This is because the variables which define $root_prefix are also part of $prefix so you end up with part of the path being used twice, first as part of 'lib=' in do_compile, and secondly as part of 'prefix=' in do_install. When $root_prefix is "" this isn't noticed. By using $baselib we should not re-break the issue which commit 2c9c4a406a0f was fixing but we should avoid doubling down on the paths thus fixing the -native and usrmerge builds. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libcap/libcap_2.25.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/libcap/libcap_2.25.bb b/meta/recipes-support/libcap/libcap_2.25.bb
index 47ecf34549..6df674547c 100644
--- a/meta/recipes-support/libcap/libcap_2.25.bb
+++ b/meta/recipes-support/libcap/libcap_2.25.bb
@@ -32,7 +32,7 @@ PACKAGECONFIG[pam] = "PAM_CAP=yes,PAM_CAP=no,libpam"
EXTRA_OEMAKE = " \
INDENT= \
- lib='${base_libdir}' \
+ lib='${baselib}' \
RAISE_SETFCAP=no \
DYNAMIC=yes \
BUILD_GPERF=yes \