aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-07-20 17:49:16 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-20 12:29:35 +0100
commit72e18bb4171698a386b277b12d973e3d0fd7c4cc (patch)
tree3fbeb204de945f1e5c5df65d55cc0b17220b3d82 /meta
parent05085b2aac7ac2789e3382cfad339474a5d6f0c6 (diff)
downloadopenembedded-core-72e18bb4171698a386b277b12d973e3d0fd7c4cc.tar.gz
package_rpm: DEPLOY_DIR_RPM must exist before make index
There is a package-index.bb which will update the index, but the DEPLOY_DIR_RPM may not exist, for example, when "bitbake package-index" in a fresh build. Only the package_rpm.bbclass needs this, the package_ipk.bbclass and package_deb.bbclass doesn't need. [YOCTO #2753] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/package_rpm.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/package_rpm.bbclass b/meta/classes/package_rpm.bbclass
index d213e40dee..983be4cfd0 100644
--- a/meta/classes/package_rpm.bbclass
+++ b/meta/classes/package_rpm.bbclass
@@ -22,7 +22,7 @@ RPMCONF_HOST_BASE = "${DEPLOY_DIR_RPM}/solvedb-sdk"
# Update the Packages depsolver db in ${DEPLOY_DIR_RPM}
#
package_update_index_rpm () {
- if [ ! -z "${DEPLOY_KEEP_PACKAGES}" ]; then
+ if [ ! -z "${DEPLOY_KEEP_PACKAGES}" -o ! -e "${DEPLOY_DIR_RPM}" ]; then
return
fi
@@ -1171,6 +1171,6 @@ do_package_write_rpm[dirs] = "${PKGWRITEDIRRPM}"
do_package_write_rpm[umask] = "022"
addtask package_write_rpm before do_package_write after do_package
-PACKAGEINDEXES += "package_update_index_rpm; createrepo ${DEPLOY_DIR_RPM};"
+PACKAGEINDEXES += "package_update_index_rpm; [ ! -e ${DEPLOY_DIR_RPM} ] || createrepo ${DEPLOY_DIR_RPM};"
PACKAGEINDEXDEPS += "rpm-native:do_populate_sysroot"
PACKAGEINDEXDEPS += "createrepo-native:do_populate_sysroot"