aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-12-13 01:23:56 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2010-12-13 01:23:56 -0500
commit69ad383525657b44dc7eeb347e888deebb501b00 (patch)
tree127a01a93efc2ee88207c101b5a95f53a4d58a04 /meta
parenta6e6af91a9044782e8bf2e4582e98eacc123c2fc (diff)
downloadopenembedded-core-69ad383525657b44dc7eeb347e888deebb501b00.tar.gz
linux-yocto: fix machine compatibility
During the last phase of the recipe factoring, the board compatibility lists ended up in the wrong place, which meant we had an incomplete list of boards, and the same set of boards for both kernels (stable and devel). To fix this, I've yanked the compatibility to the recipes themselves and updated the emenlow to have a -stable bbappend. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-stable_git.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto.inc2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_git.bb1
3 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-stable_git.bb b/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
index 8ecd86fa9f..dd4d176ac5 100644
--- a/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
@@ -17,6 +17,8 @@ PR = "r0"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRCREV_FORMAT = "meta_machine"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro|mpc8315e-rdb|beagleboard)"
+
# this performs a fixup on the SRCREV for new/undefined BSPs
python __anonymous () {
import bb, re
diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
index 095b3375fa..2a77f4a9c4 100644
--- a/meta/recipes-kernel/linux/linux-yocto.inc
+++ b/meta/recipes-kernel/linux/linux-yocto.inc
@@ -7,8 +7,6 @@ LICENSE = "GPL"
# and it can be specific to the machine or shared
KMACHINE = "UNDEFINED"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro)"
-
# Set this to 'preempt_rt' in the local.conf if you want a real time kernel
LINUX_KERNEL_TYPE ?= standard
diff --git a/meta/recipes-kernel/linux/linux-yocto_git.bb b/meta/recipes-kernel/linux/linux-yocto_git.bb
index 1e3df478eb..f40fe38fcd 100644
--- a/meta/recipes-kernel/linux/linux-yocto_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_git.bb
@@ -20,6 +20,7 @@ SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;noclone=1;branch=meta;name=meta"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
# Functionality flags
KERNEL_REVISION_CHECKING ?= "t"