aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-09-15 11:47:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-04 11:34:22 +0100
commit8d5a5d78f9e83c64ebddcecd7c4fd89cc1264163 (patch)
tree12c94221bc08b3c6ee5facef8d1e5b1e565fa88c /meta
parent97446651cd5128ca7a549df677c920e2463c46f9 (diff)
downloadopenembedded-core-8d5a5d78f9e83c64ebddcecd7c4fd89cc1264163.tar.gz
qt4: Fix translation support
The translation support was disable in build. The fix-translation.patch was imported from OpenEmbedded to fix a linking issue in phonon translation support. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-qt/qt4/qt-4.7.3.inc9
-rw-r--r--meta/recipes-qt/qt4/qt-4.7.3/fix-translations.patch32
-rw-r--r--meta/recipes-qt/qt4/qt4-embedded.inc2
-rw-r--r--meta/recipes-qt/qt4/qt4-native.inc2
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-nativesdk.inc2
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free.inc2
6 files changed, 40 insertions, 9 deletions
diff --git a/meta/recipes-qt/qt4/qt-4.7.3.inc b/meta/recipes-qt/qt4/qt-4.7.3.inc
index a5b8b05bff..16c7b08908 100644
--- a/meta/recipes-qt/qt4/qt-4.7.3.inc
+++ b/meta/recipes-qt/qt4/qt-4.7.3.inc
@@ -13,6 +13,7 @@ SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.
file://0009-support-2bpp.patch \
file://0001-Added-Openembedded-crossarch-option.patch \
file://blacklist-diginotar-certs.diff \
+ file://fix-translations.patch \
file://g++.conf \
file://linux.conf \
"
@@ -26,7 +27,9 @@ FILES_${QT_BASE_NAME}-tools += "${bindir}/qml"
do_configure_prepend() {
for pro in $(find ${S} -name "*.pro") ; do
- sed -i 's:$$QT_BUILD_TREE/bin/lrelease:${OE_QMAKE_LRELEASE}:g' $pro
+ sed -i \
+ -e 's:$$QT_BUILD_TREE/bin/lrelease:${OE_QMAKE_LRELEASE}:g' \
+ -e 's:qtPrepareTool(LRELEASE, lrelease):LRELEASE = ${OE_QMAKE_LRELEASE}:g' $pro
done
sed -i s:SEDME:${S}: ${WORKDIR}/linux.conf
@@ -38,10 +41,6 @@ do_configure_prepend() {
${S}/configure
}
-do_configure_append() {
- sed -e '/QMAKE_TARGET /d' -e '/TARGET /d' -i ${S}/translations/Makefile
-}
-
QT_GLFLAGS ?= ""
QT_CONFIG_FLAGS += " -xmlpatterns -no-rpath -qt3support -reduce-relocations -silent ${QT_GLFLAGS}"
diff --git a/meta/recipes-qt/qt4/qt-4.7.3/fix-translations.patch b/meta/recipes-qt/qt4/qt-4.7.3/fix-translations.patch
new file mode 100644
index 0000000000..906d4e312f
--- /dev/null
+++ b/meta/recipes-qt/qt4/qt-4.7.3/fix-translations.patch
@@ -0,0 +1,32 @@
+fix phony translation linking error
+
+ | .../usr/lib/crt1.o: In function `_start':
+ | .../../sysdeps/i386/elf/start.S:115: undefined reference to `main'
+ | collect2: ld returned 1 exit status
+
+Upstream-Status: Pending
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+
+diff --git a/translations/translations.pro b/translations/translations.pro
+index cdaf04a..24fa668 100644
+--- a/translations/translations.pro
++++ b/translations/translations.pro
+@@ -20,7 +20,7 @@ updateqm.name = LRELEASE ${QMAKE_FILE_IN}
+ updateqm.CONFIG += no_link
+ QMAKE_EXTRA_COMPILERS += updateqm
+
+-isEmpty(vcproj) {
++!isEmpty(vcproj) {
+ QMAKE_LINK = @: IGNORE THIS LINE
+ OBJECTS_DIR =
+ win32:CONFIG -= embed_manifest_exe
+@@ -30,7 +30,7 @@ isEmpty(vcproj) {
+ phony_src.input = PHONY_DEPS
+ phony_src.output = phony.c
+ phony_src.variable_out = GENERATED_SOURCES
+- phony_src.commands = echo int main() { return 0; } > phony.c
++ phony_src.commands = echo \"int main() { return 0; }\" > phony.c
+ phony_src.name = CREATE phony.c
+ phony_src.CONFIG += combine
+ QMAKE_EXTRA_COMPILERS += phony_src
diff --git a/meta/recipes-qt/qt4/qt4-embedded.inc b/meta/recipes-qt/qt4/qt4-embedded.inc
index ffa5288b6f..53e1297076 100644
--- a/meta/recipes-qt/qt4/qt4-embedded.inc
+++ b/meta/recipes-qt/qt4/qt4-embedded.inc
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "LGPLv2.1 | GPLv3"
HOMEPAGE = "http://qt.nokia.com"
DEPENDS += "directfb tslib"
-INC_PR = "r33"
+INC_PR = "r34"
QT_BASE_NAME ?= "qt4-embedded"
QT_BASE_LIB ?= "libqt-embedded"
diff --git a/meta/recipes-qt/qt4/qt4-native.inc b/meta/recipes-qt/qt4/qt4-native.inc
index 59c005926a..ebbee9be25 100644
--- a/meta/recipes-qt/qt4/qt4-native.inc
+++ b/meta/recipes-qt/qt4/qt4-native.inc
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24 \
file://LICENSE.GPL3;md5=babc5b6b77441da277f5c06b2e547720 \
file://LGPL_EXCEPTION.txt;md5=411080a56ff917a5a1aa08c98acae354"
-INC_PR = "r12"
+INC_PR = "r13"
inherit native
diff --git a/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc b/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
index 097fadc980..a71c3ae7b0 100644
--- a/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
+++ b/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
@@ -4,7 +4,7 @@ SECTION = "libs"
HOMEPAGE = "http://qt.nokia.com"
LICENSE = "LGPLv2.1 | GPLv3"
-INC_PR = "r6"
+INC_PR = "r7"
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qt-${PV}:"
diff --git a/meta/recipes-qt/qt4/qt4-x11-free.inc b/meta/recipes-qt/qt4/qt4-x11-free.inc
index 93feb0ed34..f76a97f932 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free.inc
+++ b/meta/recipes-qt/qt4/qt4-x11-free.inc
@@ -5,7 +5,7 @@ HOMEPAGE = "http://qt.nokia.com"
SECTION = "x11/libs"
DEPENDS += "virtual/libgl virtual/libx11 fontconfig libxft libxext libxrender libxrandr libxcursor"
-INC_PR = "r30"
+INC_PR = "r31"
QT_GLFLAGS ?= "${@base_contains('DISTRO_FEATURES', 'opengl', '-opengl', '-no-opengl', d)} "
QT_GLFLAGS_qemux86 = "-opengl"