aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:30:47 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:30:47 +0100
commitaef499ba1356f7f21f0f2589da74fa1ea82718c9 (patch)
tree2809c6970a8bb959a1c5f4e29816f94f82a248ec /meta
parent9dd2d6b7ee36af6229eb9e9c448eab3a6895a9c5 (diff)
downloadopenembedded-core-aef499ba1356f7f21f0f2589da74fa1ea82718c9.tar.gz
eglibc: Fix version 2.12 after locale changes
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/eglibc/eglibc-initial.inc4
-rw-r--r--meta/recipes-core/eglibc/eglibc-initial_2.13.bb4
-rw-r--r--meta/recipes-core/eglibc/eglibc-locale.inc58
-rw-r--r--meta/recipes-core/eglibc/eglibc-locale_2.12.bb1
-rw-r--r--meta/recipes-core/eglibc/eglibc-locale_2.13.bb59
-rw-r--r--meta/recipes-core/eglibc/eglibc-package.inc12
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb12
7 files changed, 76 insertions, 74 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-initial.inc b/meta/recipes-core/eglibc/eglibc-initial.inc
index ce85d99096..448f73a971 100644
--- a/meta/recipes-core/eglibc/eglibc-initial.inc
+++ b/meta/recipes-core/eglibc/eglibc-initial.inc
@@ -52,6 +52,10 @@ do_install () {
done
}
+do_install_locale() {
+ :
+}
+
do_siteconfig () {
:
}
diff --git a/meta/recipes-core/eglibc/eglibc-initial_2.13.bb b/meta/recipes-core/eglibc/eglibc-initial_2.13.bb
index b934f5b1bb..787c762609 100644
--- a/meta/recipes-core/eglibc/eglibc-initial_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc-initial_2.13.bb
@@ -1,10 +1,6 @@
require eglibc_${PV}.bb
require eglibc-initial.inc
-do_install_locale() {
- :
-}
-
do_configure_prepend () {
unset CFLAGS
}
diff --git a/meta/recipes-core/eglibc/eglibc-locale.inc b/meta/recipes-core/eglibc/eglibc-locale.inc
new file mode 100644
index 0000000000..ed6c099c6c
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-locale.inc
@@ -0,0 +1,58 @@
+INHIBIT_DEFAULT_DEPS = "1"
+LICENSE = "LGPL"
+
+BPN = "eglibc"
+
+do_fetch[noexec] = "1"
+do_unpack[noexec] = "1"
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+# Binary locales are generated at build time if ENABLE_BINARY_LOCALE_GENERATION
+# is set. The idea is to avoid running localedef on the target (at first boot)
+# to decrease initial boot time and avoid localedef being killed by the OOM
+# killer which used to effectively break i18n on machines with < 128MB RAM.
+
+# default to disabled
+ENABLE_BINARY_LOCALE_GENERATION ?= "0"
+ENABLE_BINARY_LOCALE_GENERATION_pn-eglibc-locale-nativesdk = "0"
+
+#enable locale generation on these arches
+# BINARY_LOCALE_ARCHES is a space separated list of regular expressions
+BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
+
+# set "1" to use cross-localedef for locale generation
+# set "0" for qemu emulation of native localedef for locale generation
+LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
+
+PR = "r0"
+
+PKGSUFFIX = ""
+PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
+
+PACKAGES = "eglibc-locale localedef${PKGSUFFIX}"
+
+PACKAGES_DYNAMIC = "locale-base-* \
+ eglibc-gconv-* eglibc-charmap-* eglibc-localedata-* eglibc-binary-localedata-* \
+ glibc-gconv-*${PKGSUFFIX} glibc-charmap-* glibc-localedata-* glibc-binary-localedata-*"
+
+PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
+
+RPROVIDES_eglibc-locale = "glibc-locale"
+
+FILES_eglibc-gconv = "${libdir}/gconv/*"
+FILES_localedef${PKGSUFFIX} = "${bindir}/localedef"
+
+do_install () {
+ cp -fpPR ${STAGING_INCDIR}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}/* ${D}
+ cp -fpPR ${D}/SUPPORTED ${WORKDIR}
+}
+
+DESCRIPTION_localedef = "eglibc: compile locale definition files"
+
+inherit libc-package
+
+do_install[depends] += "virtual/libc${PKGSUFFIX}:do_populate_sysroot"
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-core/eglibc/eglibc-locale_2.12.bb b/meta/recipes-core/eglibc/eglibc-locale_2.12.bb
new file mode 100644
index 0000000000..ce6c1d2320
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-locale_2.12.bb
@@ -0,0 +1 @@
+require eglibc-locale.inc
diff --git a/meta/recipes-core/eglibc/eglibc-locale_2.13.bb b/meta/recipes-core/eglibc/eglibc-locale_2.13.bb
index ed6c099c6c..ce6c1d2320 100644
--- a/meta/recipes-core/eglibc/eglibc-locale_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc-locale_2.13.bb
@@ -1,58 +1 @@
-INHIBIT_DEFAULT_DEPS = "1"
-LICENSE = "LGPL"
-
-BPN = "eglibc"
-
-do_fetch[noexec] = "1"
-do_unpack[noexec] = "1"
-do_patch[noexec] = "1"
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-# Binary locales are generated at build time if ENABLE_BINARY_LOCALE_GENERATION
-# is set. The idea is to avoid running localedef on the target (at first boot)
-# to decrease initial boot time and avoid localedef being killed by the OOM
-# killer which used to effectively break i18n on machines with < 128MB RAM.
-
-# default to disabled
-ENABLE_BINARY_LOCALE_GENERATION ?= "0"
-ENABLE_BINARY_LOCALE_GENERATION_pn-eglibc-locale-nativesdk = "0"
-
-#enable locale generation on these arches
-# BINARY_LOCALE_ARCHES is a space separated list of regular expressions
-BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
-
-# set "1" to use cross-localedef for locale generation
-# set "0" for qemu emulation of native localedef for locale generation
-LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
-
-PR = "r0"
-
-PKGSUFFIX = ""
-PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
-
-PACKAGES = "eglibc-locale localedef${PKGSUFFIX}"
-
-PACKAGES_DYNAMIC = "locale-base-* \
- eglibc-gconv-* eglibc-charmap-* eglibc-localedata-* eglibc-binary-localedata-* \
- glibc-gconv-*${PKGSUFFIX} glibc-charmap-* glibc-localedata-* glibc-binary-localedata-*"
-
-PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
-
-RPROVIDES_eglibc-locale = "glibc-locale"
-
-FILES_eglibc-gconv = "${libdir}/gconv/*"
-FILES_localedef${PKGSUFFIX} = "${bindir}/localedef"
-
-do_install () {
- cp -fpPR ${STAGING_INCDIR}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}/* ${D}
- cp -fpPR ${D}/SUPPORTED ${WORKDIR}
-}
-
-DESCRIPTION_localedef = "eglibc: compile locale definition files"
-
-inherit libc-package
-
-do_install[depends] += "virtual/libc${PKGSUFFIX}:do_populate_sysroot"
-
-BBCLASSEXTEND = "nativesdk"
+require eglibc-locale.inc
diff --git a/meta/recipes-core/eglibc/eglibc-package.inc b/meta/recipes-core/eglibc/eglibc-package.inc
index fd8fee8031..8228484815 100644
--- a/meta/recipes-core/eglibc/eglibc-package.inc
+++ b/meta/recipes-core/eglibc/eglibc-package.inc
@@ -88,3 +88,15 @@ DESCRIPTION_libsotruss = "Library to support sotruss which traces calls through
inherit libc-common
+do_install_locale () {
+ dest=${D}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
+ install -d ${dest} ${dest}${bindir}
+ cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
+ cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
+ cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
+ cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
+ cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
+}
+
+addtask do_install_locale after do_install before do_populate_sysroot
+
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index 603d9cdc62..3490d2db9f 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -110,18 +110,6 @@ do_compile () {
)
}
-do_install_locale () {
- dest=${D}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
- install -d ${dest} ${dest}${bindir}
- cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
- cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
- cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
- cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
- cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
-}
-
-addtask do_install_locale after do_install before do_populate_sysroot
-
require eglibc-package.inc
BBCLASSEXTEND = "nativesdk"