summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2021-10-08 16:33:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-09 17:21:44 +0100
commit722d58bccd5616b3b3364845bbf1121d3cc0c3cd (patch)
tree0721fae40f8b64ce45ff8778b92da63ba7b9256b /meta
parent4663f06c81285aeab8e8d33ec5338d7854b9dd9f (diff)
downloadopenembedded-core-722d58bccd5616b3b3364845bbf1121d3cc0c3cd.tar.gz
lttng-ust: fix do_compile failure for arm32 with DEBUG_BUILD enabled
After upgrade to 2.13.0, for arm32, with DEBUG_BUILD enabled, lttng-ust build failed with error: | /path/to/tmp/work/cortexa15t2hf-neon-poky-linux-gnueabi/lttng-ust/2_2.13.0-r0/recipe-sysroot-native/usr/bin/arm-poky-linux-gnueabi/../../libexec/arm-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/11.2.0/ld: ../../../src/lib/lttng-ust/.libs/liblttng-ust.so: undefined reference to `_uatomic_link_error' | collect2: error: ld returned 1 exit status | Makefile:399: recipe for target 'test_ust_error' failed | make[3]: *** [test_ust_error] Error 1 The problem has reported to upstream, and upstream suggests to use -DUATOMIC_NO_LINK_ERROR for the failure case, refer [1]. [1]https://lists.lttng.org/pipermail/lttng-dev/2021-September/030056.html Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.13.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.13.0.bb b/meta/recipes-kernel/lttng/lttng-ust_2.13.0.bb
index 4ec92c0683..7c6a0743e1 100644
--- a/meta/recipes-kernel/lttng/lttng-ust_2.13.0.bb
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.13.0.bb
@@ -16,6 +16,7 @@ inherit autotools lib_package manpages python3native pkgconfig
include lttng-platforms.inc
EXTRA_OECONF = "--disable-numa"
+CPPFLAGS:append:arm = "${@oe.utils.vartrue('DEBUG_BUILD', '-DUATOMIC_NO_LINK_ERROR', '', d)}"
DEPENDS = "liburcu util-linux"
RDEPENDS:${PN}-bin = "python3-core"