aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-08-31 11:42:01 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-31 16:45:38 +0100
commit1f0ba7c2b0429909ead5ae8fc015a827b08edf85 (patch)
treea9679e910c26fd805fcf84085f9bdce0588ffa16 /meta
parent4c00be1ecbfbad481a818a8275d7214458faee32 (diff)
downloadopenembedded-core-1f0ba7c2b0429909ead5ae8fc015a827b08edf85.tar.gz
sed: Fix ppc build failure
sed will firstly check whether there is a working getline function in system, if not (ppc), it use its self-defined getline(). However in 4.1.2, this function definition is not match with its declaration. Fixes [BUGID #243] Also fixes metadata. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/sed/sed-4.1.2/fix_return_type.patch16
-rw-r--r--meta/packages/sed/sed_4.1.2.bb12
2 files changed, 24 insertions, 4 deletions
diff --git a/meta/packages/sed/sed-4.1.2/fix_return_type.patch b/meta/packages/sed/sed-4.1.2/fix_return_type.patch
new file mode 100644
index 0000000000..d91960b3ee
--- /dev/null
+++ b/meta/packages/sed/sed-4.1.2/fix_return_type.patch
@@ -0,0 +1,16 @@
+Change the getline return type to match its declaration.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -urN sed-4.1.2-orig/lib/getline.c sed-4.1.2/lib/getline.c
+--- sed-4.1.2-orig/lib/getline.c 2010-08-31 08:47:50.070094024 +0800
++++ sed-4.1.2/lib/getline.c 2010-08-31 08:48:50.982178172 +0800
+@@ -30,7 +30,7 @@
+ necessary. Returns the number of characters read (not including the
+ null terminator), or -1 on error or EOF. */
+
+-size_t
++ssize_t
+ getline (lineptr, n, stream)
+ char **lineptr;
+ size_t *n;
diff --git a/meta/packages/sed/sed_4.1.2.bb b/meta/packages/sed/sed_4.1.2.bb
index 90bcc74f5c..09bd3e18cc 100644
--- a/meta/packages/sed/sed_4.1.2.bb
+++ b/meta/packages/sed/sed_4.1.2.bb
@@ -1,11 +1,15 @@
-LICENSE = "GPL"
-SECTION = "console/utils"
DESCRIPTION = "sed is a Stream EDitor."
-PR = "r2"
+HOMEPAGE = "http://www.gnu.org/software/sed/"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://sed/sed.h;beginline=1;endline=17;md5=e00ffd1837f298439a214fd197f6a407"
+SECTION = "console/utils"
+PR = "r3"
DEPENDS = "gettext"
-SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \
+ file://fix_return_type.patch"
inherit autotools