aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:40 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commit738005f4713c0da7bc04582a41efa956efdb9cc0 (patch)
tree6fa45eff2351a79ae9fbc16acb2a5ff3a118a4c5 /meta
parent3063126e2c8ec72e900a48f7048aaf9662606792 (diff)
downloadopenembedded-core-738005f4713c0da7bc04582a41efa956efdb9cc0.tar.gz
qemu-config: split out shutdown icon to its own recipe
Cleanly shutting down the machine from Sato is useful on other machines, not all of which have a power button that otherwise enables this, so make it not specific to qemu* and add it to task-core-x11-sato. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb11
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb1
-rw-r--r--meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb20
-rw-r--r--meta/recipes-sato/shutdown-desktop/shutdown-desktop/shutdown.desktop (renamed from meta/recipes-bsp/qemu-config/qemu-config/shutdown.desktop)0
4 files changed, 22 insertions, 10 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index 4179fc0492..06f2f326b4 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -10,8 +10,7 @@ COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
PR = "r25"
SRC_URI = "file://distcc.sh \
- file://exports \
- file://shutdown.desktop"
+ file://exports"
S = "${WORKDIR}"
@@ -20,14 +19,6 @@ do_install() {
install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
install -m 0644 exports ${D}${sysconfdir}/
-
- install -d ${D}${datadir}/applications
- install -m 0644 shutdown.desktop ${D}${datadir}/applications/
-}
-
-pkg_postinst_${PN} () {
- grep -q qemuarm $D${sysconfdir}/hostname && \
- sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
}
RDEPENDS_${PN} = "distcc packagegroup-core-nfs-server oprofileui-server bash"
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
index 5d781ae2fe..53e15d3550 100644
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -37,6 +37,7 @@ RDEPENDS_${PN}-base = "\
sato-icon-theme \
settings-daemon \
gtk-sato-engine \
+ shutdown-desktop \
libsdl \
${NETWORK_MANAGER} \
"
diff --git a/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
new file mode 100644
index 0000000000..d0f507e673
--- /dev/null
+++ b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Provides an icon to shut down the system cleanly"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://shutdown.desktop"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 shutdown.desktop ${D}${datadir}/applications/
+}
+
+pkg_postinst_${PN} () {
+ grep -q qemuarm $D${sysconfdir}/hostname && \
+ sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
+}
+
+inherit allarch
diff --git a/meta/recipes-bsp/qemu-config/qemu-config/shutdown.desktop b/meta/recipes-sato/shutdown-desktop/shutdown-desktop/shutdown.desktop
index 272688922c..272688922c 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config/shutdown.desktop
+++ b/meta/recipes-sato/shutdown-desktop/shutdown-desktop/shutdown.desktop