summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-16 23:49:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-16 23:50:45 +0000
commit17b3044d7508a921916da4979ff8bfbab1e206ce (patch)
tree5c7d0f860b52084ce11549b63e4aca6335558f37 /meta
parentc136652f9c0b35aafa393e63567daf029ae03929 (diff)
downloadopenembedded-core-17b3044d7508a921916da4979ff8bfbab1e206ce.tar.gz
rng-tools: Fix underquoted m4 and libgcrypt floating dependency
The underquoted m4 caused build failures if libgcrypt wasn't present. The floating dependency on libgcrypt was just plain incorrect, particularly given the incorrect libgcrypt RDEPENDS. Change to use PACKAGECONFIG an default to on. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/rng-tools/rng-tools/underquote.patch31
-rw-r--r--meta/recipes-support/rng-tools/rng-tools_5.bb6
2 files changed, 34 insertions, 3 deletions
diff --git a/meta/recipes-support/rng-tools/rng-tools/underquote.patch b/meta/recipes-support/rng-tools/rng-tools/underquote.patch
new file mode 100644
index 0000000000..1422571818
--- /dev/null
+++ b/meta/recipes-support/rng-tools/rng-tools/underquote.patch
@@ -0,0 +1,31 @@
+Fix underquoted m4 entry. This causes a failure if gcrypt isn't present:
+
+| configure: libgcrypt support disabled
+| ../rng-tools-5/configure: line 4345: ac_fn_c_try_link: command not found
+| configure: error: in `/media/build1/poky/build/tmp/work/i586-poky-linux/rng-tools/5-r0/build':
+
+RP
+2016/2/16
+
+Index: rng-tools-5/configure.ac
+===================================================================
+--- rng-tools-5.orig/configure.ac
++++ rng-tools-5/configure.ac
+@@ -71,7 +71,7 @@ AS_IF(
+ [test "x$with_libgcrypt" != "xno"],
+ [
+ AC_CHECK_HEADER([gcrypt.h],
+- AC_CHECK_LIB(
++ [AC_CHECK_LIB(
+ [gcrypt],
+ [gcry_check_version], ,
+ [
+@@ -80,7 +80,7 @@ AS_IF(
+ AC_MSG_NOTICE([libgcrypt support disabled])
+ fi
+ ]
+- ),
++ )],
+ [if test "x$with_libgcrypt" != "xcheck"; then
+ AC_MSG_FAILURE([libgcrypt headers not found]); else
+ AC_MSG_NOTICE([libgcrypt support disabled])
diff --git a/meta/recipes-support/rng-tools/rng-tools_5.bb b/meta/recipes-support/rng-tools/rng-tools_5.bb
index 9a19d1cb42..bc679904eb 100644
--- a/meta/recipes-support/rng-tools/rng-tools_5.bb
+++ b/meta/recipes-support/rng-tools/rng-tools_5.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0b6f033afe6db235e559456585dc8cdc"
SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/gkernel/${BP}.tar.gz \
file://0001-If-the-libc-is-lacking-argp-use-libargp.patch \
file://0002-Add-argument-to-control-the-libargp-dependency.patch \
+ file://underquote.patch \
file://init \
file://default"
@@ -20,12 +21,11 @@ python () {
inherit autotools update-rc.d
-PACKAGECONFIG = ""
+PACKAGECONFIG = "libgcrypt"
PACKAGECONFIG_libc-musl = "libargp"
PACKAGECONFIG_libc-uclibc = "libargp"
PACKAGECONFIG[libargp] = "--with-libargp,--without-libargp,argp-standalone,"
-
-RDEPENDS_${PN} = "libgcrypt"
+PACKAGECONFIG[libgcrypt] = "--with-libgcrypt,--without-libgcrypt,libgcrypt,"
do_install_append() {
# Only install the init script when 'sysvinit' is in DISTRO_FEATURES.