summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-05 13:38:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-18 11:29:05 +0100
commit4a1a20325e2d40256e03ab1a5be348a4c213d181 (patch)
tree4cf1fa4a66ab4c09b13b014e4d80d5b2ea8c5edb /meta
parentfde4cb18e28e98f934c0742292f7ec183a568233 (diff)
downloadopenembedded-core-4a1a20325e2d40256e03ab1a5be348a4c213d181.tar.gz
vte: Upgrade to 0.64.0 release
Use git for SRC_URI as thi release has not appeared on gnome downloads yet Drop LGPL-2.0 as it has fully moved to LGPL-3.1+ see [1] that also covers for change in License checksums for GPL-3 Add license information to cover for Xterm files in libvte Add new glade files into -dev package [1] https://github.com/GNOME/vte/commit/5e14529d4219f3792690566ef7ec70febd87e070 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/vte/vte/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch15
-rw-r--r--meta/recipes-support/vte/vte_0.64.0.bb (renamed from meta/recipes-support/vte/vte_0.62.3.bb)13
2 files changed, 16 insertions, 12 deletions
diff --git a/meta/recipes-support/vte/vte/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch b/meta/recipes-support/vte/vte/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch
index a1d2e7ff27..b4100fc381 100644
--- a/meta/recipes-support/vte/vte/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch
+++ b/meta/recipes-support/vte/vte/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch
@@ -17,20 +17,19 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
src/widget.cc | 1 +
2 files changed, 5 insertions(+)
-diff --git a/src/missing.hh b/src/missing.hh
-index 0742270..30ede62 100644
--- a/src/missing.hh
+++ b/src/missing.hh
-@@ -33,3 +33,7 @@ int fdwalk(int (*cb)(void* data, int fd),
- char* strchrnul(char const* s,
- int c);
+@@ -24,6 +24,10 @@
+ #define NSIG (8 * sizeof(sigset_t))
#endif
-+
+
+#ifndef W_EXITCODE
+#define W_EXITCODE(ret, sig) ((ret) << 8 | (sig))
+#endif
-diff --git a/src/widget.cc b/src/widget.cc
-index 44a2271..0668735 100644
++
+ #ifndef HAVE_FDWALK
+ int fdwalk(int (*cb)(void* data, int fd),
+ void* data);
--- a/src/widget.cc
+++ b/src/widget.cc
@@ -21,6 +21,7 @@
diff --git a/meta/recipes-support/vte/vte_0.62.3.bb b/meta/recipes-support/vte/vte_0.64.0.bb
index 8d2470cad8..a16dac7e67 100644
--- a/meta/recipes-support/vte/vte_0.62.3.bb
+++ b/meta/recipes-support/vte/vte_0.64.0.bb
@@ -2,13 +2,13 @@ SUMMARY = "Virtual terminal emulator GTK+ widget library"
DESCRIPTION = "VTE provides a virtual terminal widget for GTK applications."
HOMEPAGE = "https://wiki.gnome.org/Apps/Terminal/VTE"
BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
-LICENSE = "GPLv3 & LGPLv3+ & LGPLv2.1+"
+LICENSE = "GPLv3 & LGPLv3+ & MIT-X"
LICENSE_libvte = "LGPLv3+"
LIC_FILES_CHKSUM = " \
- file://COPYING.GPL3;md5=2f31b266d3440dd7ee50f92cf67d8e6c \
- file://COPYING.LGPL2;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING.GPL3;md5=cc702cf3444d1f19680c794cc61948f9 \
file://COPYING.LGPL3;md5=b52f2d57d10c4f7ee67a7eb9615d5d24 \
+ file://COPYING.XTERM;md5=d7fc3a23c16c039afafe2e042030f057 \
"
DEPENDS = "glib-2.0 gtk+3 libpcre2 libxml2-native gperf-native icu"
@@ -18,9 +18,12 @@ GIR_MESON_OPTION = 'gir'
inherit gnomebase gtk-doc features_check upstream-version-is-even gobject-introspection
+SRCREV = "2520d6b6785646ceb5f501f9c37a1a0307fa4486"
+SRC_URI = "git://gitlab.gnome.org/GNOME/vte.git;protocol=https;branch=vte-0-64"
# vapigen.m4 is required when vala is not present (but the one from vala should be used normally)
SRC_URI += "file://0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch"
-SRC_URI[archive.sha256sum] = "f5770285a52cc23a3c0428a43d492b7c0ba458ce7b8a73768a7d4f1e8a7db3b4"
+
+S = "${WORKDIR}/git"
ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
@@ -56,4 +59,6 @@ FILES_${PN}-prompt = " \
${libexecdir}/vte-urlencode-cwd \
"
+FILES_${PN}-dev += "${datadir}/glade/"
+
BBCLASSEXTEND = "native nativesdk"