summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-09 12:03:24 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-09 13:06:14 +0100
commit55a22b7341571179d5e026d102953a6d9f2045bf (patch)
treed3de355e40798d575e6f3a80168f442d78d0e345 /meta
parent161abcd3672f83990ede03d67b7388678c07150e (diff)
downloadopenembedded-core-55a22b7341571179d5e026d102953a6d9f2045bf.tar.gz
qemu: Add backported patch to address random segfaults
We've been seeing random sefgaults on a variety of architectures which appear to be from an issue in qemu. The attached backport from upstream appears to fix these. [YOCTO #4216] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/qemu/files/3f08ffb4a4741d147634761dc053ed386243a0de.patch42
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.4.0.bb2
2 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/files/3f08ffb4a4741d147634761dc053ed386243a0de.patch b/meta/recipes-devtools/qemu/files/3f08ffb4a4741d147634761dc053ed386243a0de.patch
new file mode 100644
index 0000000000..6bcf3d1552
--- /dev/null
+++ b/meta/recipes-devtools/qemu/files/3f08ffb4a4741d147634761dc053ed386243a0de.patch
@@ -0,0 +1,42 @@
+Upsteream-Status: Backport
+
+[Appears to fix the random segfaults we were seeing in a variety of architectures:
+https://bugzilla.yoctoproject.org/show_bug.cgi?id=4216 ]
+
+
+From: Yeongkyoon Lee <yeongkyoon.lee@samsung.com>
+Date: Fri, 22 Mar 2013 12:50:17 +0000 (+0900)
+Subject: tcg: Fix occasional TCG broken problem when ldst optimization enabled
+X-Git-Url: http://git.qemu.org/?p=qemu.git;a=commitdiff_plain;h=52ae646d4a3ebdcdcc973492c6a56f2c49b6578f;hp=3f08ffb4a4741d147634761dc053ed386243a0de
+
+tcg: Fix occasional TCG broken problem when ldst optimization enabled
+
+is_tcg_gen_code() checks the upper limit of TCG generated code range wrong, so
+that TCG could get broken occasionally only when CONFIG_QEMU_LDST_OPTIMIZATION
+enabled. The reason is code_gen_buffer_max_size does not cover the upper range
+up to (TCG_MAX_OP_SIZE * OPC_BUF_SIZE), thus code_gen_buffer_max_size should be
+modified to code_gen_buffer_size.
+
+CC: qemu-stable@nongnu.org
+Signed-off-by: Yeongkyoon Lee <yeongkyoon.lee@samsung.com>
+Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
+Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
+---
+
+Index: qemu-1.4.0/translate-all.c
+===================================================================
+--- qemu-1.4.0.orig/translate-all.c 2013-04-09 10:58:19.000000000 +0000
++++ qemu-1.4.0/translate-all.c 2013-04-09 10:58:34.783203406 +0000
+@@ -1310,10 +1310,10 @@
+ /* check whether the given addr is in TCG generated code buffer or not */
+ bool is_tcg_gen_code(uintptr_t tc_ptr)
+ {
+- /* This can be called during code generation, code_gen_buffer_max_size
++ /* This can be called during code generation, code_gen_buffer_size
+ is used instead of code_gen_ptr for upper boundary checking */
+ return (tc_ptr >= (uintptr_t)code_gen_buffer &&
+- tc_ptr < (uintptr_t)(code_gen_buffer + code_gen_buffer_max_size));
++ tc_ptr < (uintptr_t)(code_gen_buffer + code_gen_buffer_size));
+ }
+ #endif
+
diff --git a/meta/recipes-devtools/qemu/qemu_1.4.0.bb b/meta/recipes-devtools/qemu/qemu_1.4.0.bb
index 009cd78337..e705a0386d 100644
--- a/meta/recipes-devtools/qemu/qemu_1.4.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.4.0.bb
@@ -3,6 +3,8 @@ require qemu.inc
LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
+SRC_URI += "file://3f08ffb4a4741d147634761dc053ed386243a0de.patch"
+
SRC_URI_prepend = "http://wiki.qemu.org/download/qemu-${PV}.tar.bz2"
SRC_URI[md5sum] = "78f13b774814b6b7ebcaf4f9b9204318"
SRC_URI[sha256sum] = "066297ed77408fb7588889c271a85cf3c259ad55c939315988e6062d7708eda8"