summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-10-12 09:28:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-12 18:02:35 +0100
commit5e7a75c226d4df0c066f04eaea014b8888c6bed2 (patch)
treec0871d3ceb0039b0f8ef98cb334af79048c0e6e5 /meta
parente64a30f7af87fa960b012ace92c51b88e8abae68 (diff)
downloadopenembedded-core-5e7a75c226d4df0c066f04eaea014b8888c6bed2.tar.gz
openssl: use deterministic perl Text::Template module bundled by openssl source
1. The building openssl requires to install perl Text::Template module(>=1.46), but Text::Template is a non core Perl module, openssl chooses to bundle Text::Template 1.46 into the source, for convenience. https://github.com/openssl/openssl/commit/8ff2af548303d311ce3591406111f77862875a60 2. While Text::Template < 1.46, the produced build files are gravely faulty. https://github.com/openssl/openssl/pull/6682 3. If host has installed Text::Template < 1.46 (such as CentOS-7.5 has Text:: Template 1.45). The mismatched old module was used although the right one in openssl source. So set PERL5LIB to use deterministic perl Text::Template module bundled by openssl source and ignore the one of host Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.1.bb b/meta/recipes-connectivity/openssl/openssl_1.1.1.bb
index 5a43a150f0..0351858687 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.1.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.1.bb
@@ -105,6 +105,7 @@ do_configure () {
fi
# WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
# environment variables set by bitbake. Adjust the environment variables instead.
+ PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
perl ./Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} --prefix=$useprefix --openssldir=${libdir}/ssl-1.1 --libdir=${libdir} $target
}