summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorYevhen Kyriukha <kirgene@gmail.com>2013-08-04 19:00:11 +0300
committerSaul Wold <sgw@linux.intel.com>2013-08-05 23:59:56 -0700
commit6de68622c0658e1bba509c66c137eb419cdbdabf (patch)
tree27b88eff9041856121a748347563d17668c956f3 /meta
parent7ea8da1f692721ddb6f28088820d159c86c6c61a (diff)
downloadopenembedded-core-6de68622c0658e1bba509c66c137eb419cdbdabf.tar.gz
btrfs-tools: upgrade to upstream revision.
Two patches were removed because changes that they provide are already exist. Signed-off-by: Yevhen Kyriukha <kirgene@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch36
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_use_of_gcc.patch31
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb13
3 files changed, 3 insertions, 77 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch
deleted file mode 100644
index 40175b8ffa..0000000000
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Upstream-Status: Pending
-
-Fix makefile for multithreaded (make -j ) building.
-
-btrfsctl.c
-| i586-poky-linux-gcc -m32 -march=i586 --sysroot=/intel/poky/builds/world/tmp/sysroots/qemux86 -Wp,-MMD,./.btrfsctl.o.d,-MT,btrfsctl.o -Wall -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -O2 -pipe -g -feliminate-unused-debug-types -c btrfsctl.c
-| btrfsctl.c:37:21: fatal error: version.h: No such file or directory
-| compilation terminated.
-| btrfslabel.c:40:21: fatal error: version.h: No such file or directory
-| compilation terminated.
-
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
-2012/01/02
-
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
-@@ -26,14 +26,13 @@ else
- check = ls
- endif
-
--.c.o:
-+%.o: %.c version.h
- $(check) $<
- $(CC) $(DEPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c $<
-
-+all: $(progs) manpages
-
--all: version $(progs) manpages
--
--version:
-+version.h: version.sh
- bash version.sh
-
- btrfs: $(objects) btrfs.o btrfs_cmds.o scrub.o
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_use_of_gcc.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_use_of_gcc.patch
deleted file mode 100644
index 7f6594a343..0000000000
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_use_of_gcc.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Nitin A Kamble <nitin.a.kamble@intel.com> 2011/06/09
-Upstream-Status: Pending
-
-Avoid these kinds of errors while doing cross build:
-
-| ccache i586-poky-linux-gcc -march=i586 --sysroot=/disk0/pokybuild/build0/tmp/sysroots/qemux86 -Wp,-MMD,./.btrfsctl.o.d,-MT,btrfsctl.o -Wall -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -O2 -pipe -g -feliminate-unused-debug-types -c btrfsctl.c
-| gcc -O2 -pipe -g -feliminate-unused-debug-types -o btrfsctl btrfsctl.o ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o root-tree.o dir-item.o file-item.o inode-item.o inode-map.o crc32c.o rbtree.o extent-cache.o extent_io.o volumes.o utils.o btrfs-list.o -Wl,-O1 -Wl,--as-needed -luuid
-| /usr/bin/ld: i386 architecture of input file `btrfsctl.o' is incompatible with i386:x86-64 output
-| /usr/bin/ld: i386 architecture of input file `ctree.o' is incompatible with i386:x86-64 output
-
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
-@@ -41,13 +41,13 @@ btrfs: $(objects) btrfs.o btrfs_cmds.o s
- $(objects) $(LDFLAGS) $(LIBS)
-
- calc-size: $(objects) calc-size.o
-- gcc $(CFLAGS) -o calc-size calc-size.o $(objects) $(LDFLAGS) $(LIBS)
-+ $(CC) $(CFLAGS) -o calc-size calc-size.o $(objects) $(LDFLAGS) $(LIBS)
-
- find-root: $(objects) find-root.o
-- gcc $(CFLAGS) -o find-root find-root.o $(objects) $(LDFLAGS) $(LIBS)
-+ $(CC) $(CFLAGS) -o find-root find-root.o $(objects) $(LDFLAGS) $(LIBS)
-
- restore: $(objects) restore.o
-- gcc $(CFLAGS) -o restore restore.o $(objects) $(LDFLAGS) $(LIBS) $(RESTORE_LIBS)
-+ $(CC) $(CFLAGS) -o restore restore.o $(objects) $(LDFLAGS) $(LIBS) $(RESTORE_LIBS)
-
- btrfsctl: $(objects) btrfsctl.o
- $(CC) $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
index ef575ae718..07e8529a9d 100644
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
@@ -12,21 +12,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
SECTION = "base"
DEPENDS = "util-linux attr"
-SRCREV = "fdb6c0402337d9607c7a39155088eaf033742752"
+SRCREV = "194aa4a1bd6447bb545286d0bcb0b0be8204d79f"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git;protocol=git"
S = "${WORKDIR}/git"
-PV = "0.19+git${SRCPV}"
+PV = "0.20+git${SRCPV}"
-PR = "r6"
-
-SRC_URI += " file://fix_use_of_gcc.patch \
- file://weak-defaults.patch \
- file://fix_race_condition_with_multithreaded_make.patch "
-
-SRC_URI[md5sum] = "78b1700d318de8518abfaab71f99a885"
-SRC_URI[sha256sum] = "1285774e0cb72984fac158dd046c8d405324754febd30320cd31e459253e4b65"
+SRC_URI += "file://weak-defaults.patch"
do_install () {
oe_runmake 'DESTDIR=${D}' install