summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-01-23 10:06:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-28 00:48:29 +0000
commita2a77730f28decfd2448bcda68280174b55cf54c (patch)
tree52f52966db163ba2a222907dab20c10717189317 /meta
parent68e87652ae4865a52705f8b87b4ae0f99cbc7428 (diff)
downloadopenembedded-core-a2a77730f28decfd2448bcda68280174b55cf54c.tar.gz
lz4: actually install things
This failure was masked by having lz4 installed on the host system :( Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/lz4/lz4_svn.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/lz4/lz4_svn.bb b/meta/recipes-support/lz4/lz4_svn.bb
index 41464e2351..a760313daf 100644
--- a/meta/recipes-support/lz4/lz4_svn.bb
+++ b/meta/recipes-support/lz4/lz4_svn.bb
@@ -12,6 +12,10 @@ SRC_URI = "svn://lz4.googlecode.com/svn/;module=trunk;protocol=http"
S = "${WORKDIR}/trunk"
-EXTRA_OEMAKE = "PREFIX=${prefix} CC=${TARGET_PREFIX}gcc DESTDIR=${D}"
+EXTRA_OEMAKE = "PREFIX=${prefix} CC=${TARGET_PREFIX}gcc DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+
+do_install() {
+ oe_runmake install
+}
BBCLASSEXTEND += "native nativesdk"