summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2018-03-02 17:02:00 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:36:35 -0800
commitb32f3b655189fd89dcfce084b6fda0d379300f75 (patch)
tree42c6d7f4c34ed95a06c326b61d2117202a77b73e /meta
parent54615151da5e8c77c803947ce5760d06c1691c58 (diff)
downloadopenembedded-core-b32f3b655189fd89dcfce084b6fda0d379300f75.tar.gz
e2fsprogs_1.43.8.bb: improve reproducibility
Various builds of e2fsprogs 1.43.7 package locales which may or may not have POT-Creation-Date removed. There is no obvious pattern, it affects different locales each time, the build being non-deterministic. The root cause was tracked to non-deterministic time stamps (as GIT does not preserve file mktime), so some "make" rules sometimes fired, sometimes did not. The remedy is to explicitly "touch" files that cause non-deterministic build. [YOCTO #12516] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.8.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.8.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.8.bb
index ceaf171585..4fa976d51f 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.8.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.8.bb
@@ -25,6 +25,9 @@ EXTRA_OECONF_darwin = "--libdir=${base_libdir} --sbindir=${base_sbindir} --enabl
PACKAGECONFIG ??= ""
PACKAGECONFIG[fuse] = '--enable-fuse2fs,--disable-fuse2fs,fuse'
+do_compile_prepend (){
+ find ${S}/po -type f -name "*.po" -exec touch {} +
+}
do_install () {
oe_runmake 'DESTDIR=${D}' install