summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-11-15 16:46:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-07 06:33:57 -0800
commitd7696f5f89ac94b5cae13c5e07d6d4c7133c3ed9 (patch)
tree34ba120a1e68c4d81d0d7d41f4485897f504c4d1 /meta
parent2526fcfac8e360d5d27f5ebe26608df470b3b84b (diff)
downloadopenembedded-core-d7696f5f89ac94b5cae13c5e07d6d4c7133c3ed9.tar.gz
btrfs-tools: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch17
1 files changed, 7 insertions, 10 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch
index a81900ee7e..467de32751 100644
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch
@@ -12,19 +12,16 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/Makefile b/Makefile
-index b3e2b63..347aaf1 100644
---- a/Makefile
-+++ b/Makefile
-@@ -323,7 +323,7 @@ version.h: version.sh version.h.in configure.ac
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -343,7 +343,7 @@ version.h: version.sh version.h.in confi
mktables: kernel-lib/mktables.c
@echo " [CC] $@"
- $(Q)$(CC) $(CFLAGS) $< -o $@
+ $(Q)$(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
- kernel-lib/tables.c: mktables
- @echo " [TABLE] $@"
---
-2.13.2
-
+ # the target can be regenerated manually using mktables, but a local copy is
+ # kept so the build process is simpler