summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-04-08 10:35:31 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-08 16:55:33 +0100
commitda9515621134c26e54f43b96cdad0c6e6c5876bf (patch)
tree541fc26d76c7b48c7b5afb79b5b09e1d7df5f2f7 /meta
parent0c60d3b04eb77629abc3bbc2a6d8a2b8f0a44309 (diff)
downloadopenembedded-core-da9515621134c26e54f43b96cdad0c6e6c5876bf.tar.gz
gst-ffmpeg: fix --disable-yasm
The gst-ffmpeg build shows the following warning: configure: WARNING: unrecognized options: --disable-yasm which means that the following test in configure always fails and --disable-yasm never gets passed to the embedded ffmpeg build: 'if test "x$disable_yasm" = "xyes"; then' embffmpeg_configure_args="$embffmpeg_configure_args --disable-yasm" commit 4d309730 ['gst-ffmpeg: configure-fix patch used wrong test'] actually fixed the obviously backwards syntax by reversing the test - prior to that, --disable-yasm would always unconditionally be passed into the embedded ffmpeg config. This fixes things so that the variable actually exists and makes the test meaningful. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch b/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch
index 2bb124b8bc..9ef6f7c4bf 100644
--- a/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch
+++ b/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch
@@ -7,11 +7,13 @@ Signed-off-by: Shane Wang <shane.wang@intel.com>
diff -r f2f8f74c6e30 configure.ac
--- a/configure.ac Thu Dec 22 23:56:09 2011 +0800
+++ b/configure.ac Thu Dec 22 23:57:37 2011 +0800
-@@ -325,6 +325,10 @@
+@@ -325,6 +325,12 @@
--enable-gpl"
fi
-+ if test "x$disable_yasm" = "xyes"; then
++ AC_ARG_ENABLE(yasm,
++ [AC_HELP_STRING([--disable-yasm], [disable use of yasm assembler])])
++ if test "x$enable_yasm" = "xno"; then
+ embffmpeg_configure_args="$embffmpeg_configure_args --disable-yasm"
+ fi
+