summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-05-20 16:11:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-22 07:24:38 +0100
commite920e58af56d1d1279d396bfb4e8baf38605b6d1 (patch)
treeabe8a3c16ea9459e60b42ee91e4f1a5b10297398 /meta
parent22a61a71daa7019e1b89ec5aabbecc0126e453aa (diff)
downloadopenembedded-core-e920e58af56d1d1279d396bfb4e8baf38605b6d1.tar.gz
webkitgtk: update to 2.24.2
Add a patch to address a missing format string error. Drop the x86-specifc setting for GSTREAMER_GL as it is no longer needed. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/0001-gstreamer-add-a-missing-format-string.patch24
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.24.2.bb (renamed from meta/recipes-sato/webkit/webkitgtk_2.24.0.bb)9
2 files changed, 27 insertions, 6 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/0001-gstreamer-add-a-missing-format-string.patch b/meta/recipes-sato/webkit/webkitgtk/0001-gstreamer-add-a-missing-format-string.patch
new file mode 100644
index 0000000000..bd4ac1e353
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/0001-gstreamer-add-a-missing-format-string.patch
@@ -0,0 +1,24 @@
+From 2d9687840b97186b80053dd262209e39455ac876 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Wed, 8 May 2019 15:31:23 +0200
+Subject: [PATCH] gstreamer: add a missing format string
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ .../platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp b/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp
+index e1e497ee..483fd65c 100644
+--- a/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp
++++ b/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp
+@@ -738,7 +738,7 @@ static GstStateChangeReturn webKitWebSrcChangeState(GstElement* element, GstStat
+ WebKitWebSrc* src = WEBKIT_WEB_SRC(element);
+
+ #if GST_CHECK_VERSION(1, 14, 0)
+- GST_DEBUG_OBJECT(src, gst_state_change_get_name(transition));
++ GST_DEBUG_OBJECT(src, "%s", gst_state_change_get_name(transition));
+ #endif
+ switch (transition) {
+ case GST_STATE_CHANGE_READY_TO_NULL:
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb b/meta/recipes-sato/webkit/webkitgtk_2.24.2.bb
index 96ac5ac18f..056334fff5 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.24.2.bb
@@ -23,10 +23,11 @@ SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://include_array.patch \
file://narrowing.patch \
file://snprintf.patch \
+ file://0001-gstreamer-add-a-missing-format-string.patch \
"
-SRC_URI[md5sum] = "576d69c598b3e36c73441052d02466de"
-SRC_URI[sha256sum] = "2e4ad1503fe482ceb5a83cf70ac9cd42f37eb718555a4d6844fe4c59a9214407"
+SRC_URI[md5sum] = "83012998e1b9f71abb37d8baf6f9c7e6"
+SRC_URI[sha256sum] = "019cb1f0d05bf6148b72c7a85734bcd006388a1c14132843ef9a1b2cb7b4321c"
inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc
@@ -71,10 +72,6 @@ EXTRA_OECMAKE = " \
-DPYTHON_EXECUTABLE=`which python` \
"
-# GL/GLES header clash: both define the same thing, differently, on 32 bit x86
-EXTRA_OECMAKE_append_x86 = " -DUSE_GSTREAMER_GL=OFF "
-EXTRA_OECMAKE_append_x86-x32 = " -DUSE_GSTREAMER_GL=OFF "
-
# Javascript JIT is not supported on ARC
EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
# By default 25-bit "medium" calls are used on ARC