summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-28 21:42:29 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-01 15:38:21 +0100
commitf2abe18d2a3c9c4ff2b6b442bc496fd3b2203598 (patch)
tree7a6c1db8514809169f19c0b1f6d842ee57b00d15 /meta
parent5a70e45b8c6cb0fa7ea4fe1b326ad604508d00cb (diff)
downloadopenembedded-core-f2abe18d2a3c9c4ff2b6b442bc496fd3b2203598.tar.gz
gdbm 1.8.3: install ndbm.h and dbm.h
There are gdbm 1.8.3 and gdbm 1.11, while 1.8.3 is GPLv2, it should install ndbm.h and dbm.h as what 1.11 does, to make perl build OK when non-gplv3 build. Fixed when perl build: (non-gplv3 buld) | NDBM_File.xs:18:60: fatal error: gdbm/ndbm.h: No such file or directory | # include <gdbm/ndbm.h> /* RedHat compatibility version */ | ^ | compilation terminated. And: | ODBM_File.xs:8:19: fatal error: dbm.h: No such file or directory | # include <dbm.h> | ^ | compilation terminated. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.8.3.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.8.3.bb b/meta/recipes-support/gdbm/gdbm_1.8.3.bb
index 2331d1df3a..af01b6c407 100644
--- a/meta/recipes-support/gdbm/gdbm_1.8.3.bb
+++ b/meta/recipes-support/gdbm/gdbm_1.8.3.bb
@@ -17,3 +17,13 @@ SRC_URI[sha256sum] = "cc340338a2e28b40058ab9eb5354a21d53f88a1582ea21ba0bb185c37a
inherit autotools texinfo
BBCLASSEXTEND = "native nativesdk"
+
+do_install_append () {
+ install -d ${D}${includedir}/gdbm
+ install -m 0644 ${S}/dbm.h ${D}${includedir}/
+ install -m 0644 ${S}/ndbm.h ${D}${includedir}/
+ # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
+ # these headers
+ ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
+ ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
+}