summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-09-06 12:29:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-06 23:43:34 +0100
commitfb646ea311c589a51ef76eea7581e63f8a8f6bbd (patch)
treef4d10784b21d0638b34f8d7969cdd278222b9cdf /meta
parent68685bfc83051105ab2c5a5fb7d350ecaca2457f (diff)
downloadopenembedded-core-fb646ea311c589a51ef76eea7581e63f8a8f6bbd.tar.gz
boost: update to 1.68.0
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.68.0.bb (renamed from meta/recipes-support/boost/bjam-native_1.67.0.bb)0
-rw-r--r--meta/recipes-support/boost/boost-1.68.0.inc (renamed from meta/recipes-support/boost/boost-1.67.0.inc)4
-rw-r--r--meta/recipes-support/boost/boost/0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch76
-rw-r--r--meta/recipes-support/boost/boost_1.68.0.bb (renamed from meta/recipes-support/boost/boost_1.67.0.bb)1
4 files changed, 2 insertions, 79 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.67.0.bb b/meta/recipes-support/boost/bjam-native_1.68.0.bb
index 94f96e62d8..94f96e62d8 100644
--- a/meta/recipes-support/boost/bjam-native_1.67.0.bb
+++ b/meta/recipes-support/boost/bjam-native_1.68.0.bb
diff --git a/meta/recipes-support/boost/boost-1.67.0.inc b/meta/recipes-support/boost/boost-1.68.0.inc
index 1c7f94022d..b367a80b64 100644
--- a/meta/recipes-support/boost/boost-1.67.0.inc
+++ b/meta/recipes-support/boost/boost-1.68.0.inc
@@ -12,8 +12,8 @@ BOOST_MAJ = "${@"_".join(d.getVar("PV").split(".")[0:2])}"
BOOST_P = "boost_${BOOST_VER}"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/boost/boost/${PV}/${BOOST_P}.tar.bz2"
-SRC_URI[md5sum] = "ced776cb19428ab8488774e1415535ab"
-SRC_URI[sha256sum] = "2684c972994ee57fc5632e03bf044746f6eb45d4920c343937a465fd67a5adba"
+SRC_URI[md5sum] = "7fbd1890f571051f2a209681d57d486a"
+SRC_URI[sha256sum] = "7f6130bc3cf65f56a618888ce9d5ea704fa10b462be126ad053e80e553d6d8b7"
UPSTREAM_CHECK_URI = "http://www.boost.org/users/download/"
UPSTREAM_CHECK_REGEX = "boostorg/release/(?P<pver>.*)/source/"
diff --git a/meta/recipes-support/boost/boost/0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch b/meta/recipes-support/boost/boost/0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch
deleted file mode 100644
index 182693079a..0000000000
--- a/meta/recipes-support/boost/boost/0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From 39b027171e0a619d49b9dd2e8471d10b6c41bc25 Mon Sep 17 00:00:00 2001
-From: Andrey Semashev <andrey.semashev@gmail.com>
-Date: Tue, 17 Jul 2018 12:37:29 +0300
-Subject: [PATCH] Removed clang-specific branch for x86 DCAS-based loads.
-
-The storage to load from is const-qualified and DCAS via compiler intrinsics
-require an unqualified pointer. Use asm implementation instead, which should be
-as efficient as intrinsics, if not better, in this case.
-
-Fixes https://github.com/boostorg/atomic/issues/15.
-
-Upstream-Status: Backport [https://github.com/boostorg/atomic/commit/6e14ca24dab50ad4c1fa8c27c7dd6f1cb791b534]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- boost/atomic/detail/ops_gcc_x86_dcas.hpp | 23 ++++++++++++-----------
- 1 file changed, 12 insertions(+), 11 deletions(-)
-
-diff --git a/boost/atomic/detail/ops_gcc_x86_dcas.hpp b/boost/atomic/detail/ops_gcc_x86_dcas.hpp
-index 4dacc66f..b43ef23a 100644
---- a/boost/atomic/detail/ops_gcc_x86_dcas.hpp
-+++ b/boost/atomic/detail/ops_gcc_x86_dcas.hpp
-@@ -158,11 +158,13 @@ struct gcc_dcas_x86
- }
- else
- {
--#if defined(__clang__)
-- // Clang cannot allocate eax:edx register pairs but it has sync intrinsics
-- value = __sync_val_compare_and_swap(&storage, (storage_type)0, (storage_type)0);
--#elif defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-+ // Note that despite const qualification cmpxchg8b below may issue a store to the storage. The storage value
-+ // will not change, but this prevents the storage to reside in read-only memory.
-+
-+#if defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-+
- uint32_t value_bits[2];
-+
- // We don't care for comparison result here; the previous value will be stored into value anyway.
- // Also we don't care for ebx and ecx values, they just have to be equal to eax and edx before cmpxchg8b.
- __asm__ __volatile__
-@@ -175,7 +177,9 @@ struct gcc_dcas_x86
- : BOOST_ATOMIC_DETAIL_ASM_CLOBBER_CC_COMMA "memory"
- );
- BOOST_ATOMIC_DETAIL_MEMCPY(&value, value_bits, sizeof(value));
-+
- #else // defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-+
- // We don't care for comparison result here; the previous value will be stored into value anyway.
- // Also we don't care for ebx and ecx values, they just have to be equal to eax and edx before cmpxchg8b.
- __asm__ __volatile__
-@@ -187,6 +191,7 @@ struct gcc_dcas_x86
- : [storage] "m" (storage)
- : BOOST_ATOMIC_DETAIL_ASM_CLOBBER_CC_COMMA "memory"
- );
-+
- #endif // defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
- }
-
-@@ -401,15 +406,11 @@ struct gcc_dcas_x86_64
-
- static BOOST_FORCEINLINE storage_type load(storage_type const volatile& storage, memory_order) BOOST_NOEXCEPT
- {
--#if defined(__clang__)
-+ // Note that despite const qualification cmpxchg16b below may issue a store to the storage. The storage value
-+ // will not change, but this prevents the storage to reside in read-only memory.
-
-- // Clang cannot allocate rax:rdx register pairs but it has sync intrinsics
-- storage_type value = storage_type();
-- return __sync_val_compare_and_swap(&storage, value, value);
--
--#elif defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-+#if defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-
-- // Some compilers can't allocate rax:rdx register pair either and also don't support 128-bit __sync_val_compare_and_swap
- uint64_t value_bits[2];
-
- // We don't care for comparison result here; the previous value will be stored into value anyway.
diff --git a/meta/recipes-support/boost/boost_1.67.0.bb b/meta/recipes-support/boost/boost_1.68.0.bb
index ef178edc0c..c7958a4c5e 100644
--- a/meta/recipes-support/boost/boost_1.67.0.bb
+++ b/meta/recipes-support/boost/boost_1.68.0.bb
@@ -8,5 +8,4 @@ SRC_URI += "\
file://0001-Apply-boost-1.62.0-no-forced-flags.patch.patch \
file://0003-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
file://0001-make_x86_64_sysv_elf_gas.S-set-.file-section.patch \
- file://0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch \
"