summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2012-03-21 22:46:05 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-22 16:42:15 +0000
commitfb89e4585644db0958a633a637fc70f0459af26a (patch)
treee0962a822c6877507cb8ee08d15c4fe856e9b77e /meta
parent053f1a0200047949765f34a6c99940adbe8f2c9f (diff)
downloadopenembedded-core-fb89e4585644db0958a633a637fc70f0459af26a.tar.gz
rt-tests: add patch to support passing CFLAGS/LDFLAGS
Enable passing OE and Distro-specific CFLAGS/LDFLAGS to the Makefile. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests-0.83/makefile-support-user-cflags-ldflags.patch89
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.83.bb8
2 files changed, 94 insertions, 3 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests-0.83/makefile-support-user-cflags-ldflags.patch b/meta/recipes-rt/rt-tests/rt-tests-0.83/makefile-support-user-cflags-ldflags.patch
new file mode 100644
index 0000000000..09a5d7b812
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests-0.83/makefile-support-user-cflags-ldflags.patch
@@ -0,0 +1,89 @@
+From: Darren Hart <dvhart@linux.intel.com>
+Subject: [PATCH rt-tests RFC 4/6] Makefile: Support user supplied CFLAGS and LDFLAGS
+Date: Thu, 22 Mar 2012 02:14:04 +0100
+
+Accept user supplied CFLAGS and LDFLAGS, overwriting the
+Makefile supplied versions. This can cause the build to
+fail if the user does not provide at least what the Makefile
+defines, but so be it.
+
+Upstream-Status: Submitted [linux-rt-users@vger.kernel.org]
+
+Signed-off-by: Darren Hart <dvhart@linux.intel.com>
+CC: Clark Williams <williams@redhat.com>
+CC: John Kacur <jkacur@redhat.com>
+CC: Denys Dmytriyenko <denis@denix.org>
+Signed-off-by: John Kacur <jkacur@redhat.com>
+---
+ Makefile | 25 +++++++++++++------------
+ 1 files changed, 13 insertions(+), 12 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 4038dcc..e1edf6c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -20,7 +20,8 @@ ifneq ($(filter x86_64 i386 ia64 mips powerpc,$(machinetype)),)
+ NUMA := 1
+ endif
+
+-CFLAGS = -D_GNU_SOURCE -Wall -Wno-nonnull -Isrc/include
++CFLAGS ?= -D_GNU_SOURCE -Wall -Wno-nonnull -Isrc/include
++LDFLAGS ?=
+
+ PYLIB := $(shell python -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()')
+
+@@ -61,41 +62,41 @@ all: $(TARGETS) hwlatdetect
+ -include $(sources:.c=.d)
+
+ cyclictest: cyclictest.o rt-utils.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS) $(NUMA_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(NUMA_LIBS)
+
+ signaltest: signaltest.o rt-utils.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ pi_stress: pi_stress.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ hwlatdetect: src/hwlatdetect/hwlatdetect.py
+ chmod +x src/hwlatdetect/hwlatdetect.py
+ ln -s src/hwlatdetect/hwlatdetect.py hwlatdetect
+
+ rt-migrate-test: rt-migrate-test.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ ptsematest: ptsematest.o rt-utils.o rt-get_cpu.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
+
+ sigwaittest: sigwaittest.o rt-utils.o rt-get_cpu.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
+
+ svsematest: svsematest.o rt-utils.o rt-get_cpu.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
+
+ pmqtest: pmqtest.o rt-utils.o rt-get_cpu.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
+
+ sendme: sendme.o rt-utils.o rt-get_cpu.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(EXTRA_LIBS)
+
+ pip_stress: pip_stress.o error.o rt-utils.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ hackbench: hackbench.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ CLEANUP = $(TARGETS) *.o .depend *.*~ *.orig *.rej rt-tests.spec *.d
+ CLEANUP += $(if $(wildcard .git), ChangeLog)
+--
+1.7.7.6
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.83.bb b/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
index 1a91e867eb..6c4931e0a9 100644
--- a/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
@@ -11,13 +11,15 @@ SRCREV = "5f1e84f8b015df3ff950056494134eca3f640d70"
# git -> 0.83 needs a PE bump
PE = "1"
-PR = "r1"
+PR = "r2"
-SRC_URI = "git://github.com/clrkwllms/rt-tests.git"
+SRC_URI = "git://github.com/clrkwllms/rt-tests.git \
+ file://makefile-support-user-cflags-ldflags.patch"
S = "${WORKDIR}/git"
-CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnulli ${LDFLAGS}"
+# need to append rt-tests' default CFLAGS to ours
+CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnulli"
# calling 'uname -m' is broken on crossbuilds
EXTRA_OEMAKE = "NUMA=0"