aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorDavid Nyström <david.c.nystrom@gmail.com>2013-02-07 11:00:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-08 14:46:02 +0000
commit18e3654894175af0f51049cf2dcf42295bfbc905 (patch)
tree84235d345b289d9fc5b26e26687ea82cd6bf66a8 /scripts
parentacb0e56d79cfaa606ccd0a075a7c78ede172da86 (diff)
downloadopenembedded-core-18e3654894175af0f51049cf2dcf42295bfbc905.tar.gz
scripts/create-recipe: Bugfixes for create-recipe easy_install handling.
1. Tell easy_install to always download, regardless of python install content. 2. Support https/ftp et.c. URLs provided by easy_install Signed-off-by: David Nyström <david.nystrom@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/create-recipe6
1 files changed, 3 insertions, 3 deletions
diff --git a/scripts/create-recipe b/scripts/create-recipe
index 1b10e1b591..5613e92cb9 100755
--- a/scripts/create-recipe
+++ b/scripts/create-recipe
@@ -1918,9 +1918,9 @@ if ( -e "$dir/setup.py" ) {
if ($recurse_python == 1) {
foreach (@rawpythondeps) {
my $ptempdir = tempdir();
- $purl = `easy_install -eb $ptempdir "$_" 2>/dev/null`;
- $purl =~ s/#.*//;
- @purllist = $purl =~ m/Downloading (http:\/\/.*\n)/g;
+ $purl = `easy_install -aeb $ptempdir "$_" 2>/dev/null`;
+ $purl =~ s/#.*//g;
+ @purllist = $purl =~ m/Downloading (.*:\/\/.*\n)/g;
chomp(@purllist);
# Remove empty lines