aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-support/gnutls/gnutls/CVE-2016-7444.patch31
-rw-r--r--meta/recipes-support/gnutls/gnutls_3.3.17.1.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/gnutls/gnutls/CVE-2016-7444.patch b/meta/recipes-support/gnutls/gnutls/CVE-2016-7444.patch
new file mode 100644
index 0000000000..2bb0626d99
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls/CVE-2016-7444.patch
@@ -0,0 +1,31 @@
+From 964632f37dfdfb914ebc5e49db4fa29af35b1de9 Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
+Date: Sat, 27 Aug 2016 17:00:22 +0200
+Subject: [PATCH] ocsp: corrected the comparison of the serial size in OCSP
+ response
+
+Previously the OCSP certificate check wouldn't verify the serial length
+and could succeed in cases it shouldn't.
+
+Reported by Stefan Buehler.
+
+Upstream-Status: Backport
+CVE: CVE-2016-7444
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ lib/x509/ocsp.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: gnutls-3.3.17.1/lib/x509/ocsp.c
+===================================================================
+--- gnutls-3.3.17.1.orig/lib/x509/ocsp.c
++++ gnutls-3.3.17.1/lib/x509/ocsp.c
+@@ -1257,6 +1257,7 @@ gnutls_ocsp_resp_check_crt(gnutls_ocsp_r
+ gnutls_assert();
+ goto cleanup;
+ }
++ cserial.size = t;
+
+ if (rserial.size != cserial.size
+ || memcmp(cserial.data, rserial.data, rserial.size) != 0) {
diff --git a/meta/recipes-support/gnutls/gnutls_3.3.17.1.bb b/meta/recipes-support/gnutls/gnutls_3.3.17.1.bb
index 0185797521..99b205314e 100644
--- a/meta/recipes-support/gnutls/gnutls_3.3.17.1.bb
+++ b/meta/recipes-support/gnutls/gnutls_3.3.17.1.bb
@@ -3,6 +3,7 @@ require gnutls.inc
SRC_URI += "file://correct_rpl_gettimeofday_signature.patch \
file://configure.ac-fix-sed-command.patch \
file://use-pkg-config-to-locate-zlib.patch \
+ file://CVE-2016-7444.patch \
"
SRC_URI[md5sum] = "8d01c7e7f2cbc5871fdca832d2260b6b"
SRC_URI[sha256sum] = "b40f158030a92f450a07b20300a3996710ca19800848d9f6fd62493170c5bbb4"